# CVE-2023-50720: XWiki Platform Solr search discloses email addresses of users

> Attackers can retrieve user email addresses via Solr search even when obfuscation is enabled, exposing private user data.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Dec 2023
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-2grh-gr37-2283

## What is CVE-2023-50720?

CVE-2023-50720 is a medium-severity vulnerability in Xwiki Xwiki, published on 15 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

XWiki Platform is a generic wiki platform. Prior to versions 14.10.15, 15.5.2, and 15.7-rc-1, the Solr-based search in XWiki discloses the email addresses of users even when obfuscation of email addresses is enabled. To demonstrate the vulnerability, search for `objcontent:email*` using XWiki's regular search interface. This has been fixed in XWiki 14.10.15, 15.5.2 and 15.7RC1 by not indexing email address properties when obfuscation is enabled. There are no known workarounds for this vulnerability.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2023-50720?

6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-search-solr-api. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-search-solr-api` | Maven | All versions | 14.10.15 |
| `org.xwiki.platform:xwiki-platform-search-solr-api` | Maven | All versions | 14.10.15 |
| `org.xwiki.platform:xwiki-platform-search-solr-api` | Maven | From 15.0-rc-1 | 15.5.2 |
| `org.xwiki.platform:xwiki-platform-search-solr-api` | Maven | From 15.0-rc-1 | 15.5.2 |
| `org.xwiki.platform:xwiki-platform-search-solr-api` | Maven | From 15.6-rc-1 | 15.7-rc-1 |
| `org.xwiki.platform:xwiki-platform-search-solr-api` | Maven | From 15.6-rc-1 | 15.7-rc-1 |

Products: Xwiki Xwiki.

## How do I fix CVE-2023-50720?

Upgrade org.xwiki.platform:xwiki-platform-search-solr-api to a fixed version for your release line: 14.10.15, 15.5.2 or 15.7-rc-1.

## Is CVE-2023-50720 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-50720 exists.

Public exploit code:

- XWiki < 4.10.15 - Email Disclosure (nuclei): http/cves/2023/CVE-2023-50720.yaml

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-50720 and fix it if it is affected.

What it is: CVE-2023-50720 is a medium-severity vulnerability in Xwiki Xwiki, published on 15 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-50720 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-search-solr-api (Maven): affected all versions; fixed in 14.10.15
- org.xwiki.platform:xwiki-platform-search-solr-api (Maven): affected all versions; fixed in 14.10.15
- org.xwiki.platform:xwiki-platform-search-solr-api (Maven): affected from 15.0-rc-1; fixed in 15.5.2
- org.xwiki.platform:xwiki-platform-search-solr-api (Maven): affected from 15.0-rc-1; fixed in 15.5.2
- org.xwiki.platform:xwiki-platform-search-solr-api (Maven): affected from 15.6-rc-1; fixed in 15.7-rc-1
- org.xwiki.platform:xwiki-platform-search-solr-api (Maven): affected from 15.6-rc-1; fixed in 15.7-rc-1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-50720/ (Markdown: https://insights.sbomify.com/CVE-2023-50720/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-50720
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-50720
- OSV: https://osv.dev/vulnerability/CVE-2023-50720

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-50720/
Summaries are generated and may contain mistakes; the official description above is the record.
