CVE-2023-50721 XWiki Platform RCE from account through SearchAdmin
Authenticated users can inject Groovy scripts via search UI extensions to achieve remote code execution on the XWiki server.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-50721?
CVE-2023-50721 is a critical code injection vulnerability in Xwiki Xwiki, published on 15 Dec 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
XWiki Platform is a generic wiki platform. Starting in 4.5-rc-1 and prior to versions 14.10.15, 15.5.2, and 15.7-rc-1, the search administration interface doesn't properly escape the id and label of search user interface extensions, allowing the injection of XWiki syntax containing script macros including Groovy macros that allow remote code execution, impacting the confidentiality, integrity and availability of the whole XWiki instance. This attack can be executed by any user who can edit some wiki page like the user's profile (editable by default) as user interface extensions that will be displayed in the search administration can be added on any document by any user. The necessary escaping has been added in XWiki 14.10.15, 15.5.2 and 15.7RC1. As a workaround, the patch can be applied manually applied to the page `XWiki.SearchAdmin`.
Which versions are affected by CVE-2023-50721?
6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-search-ui. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.xwiki.platform:xwiki-platform-search-ui Maven | From 15.0-rc-1 | 15.5.2 |
org.xwiki.platform:xwiki-platform-search-ui Maven | From 15.0-rc-1 | 15.5.2 |
org.xwiki.platform:xwiki-platform-search-ui Maven | From 15.6-rc-1 | 15.7-rc-1 |
org.xwiki.platform:xwiki-platform-search-ui Maven | From 15.6-rc-1 | 15.7-rc-1 |
org.xwiki.platform:xwiki-platform-search-ui Maven | From 4.5-rc-1 | 14.10.15 |
org.xwiki.platform:xwiki-platform-search-ui Maven | From 4.5-rc-1 | 14.10.15 |
Products include Xwiki Xwiki.
How do I fix CVE-2023-50721?
Upgrade org.xwiki.platform:xwiki-platform-search-ui to a fixed version for your release line: 15.5.2, 15.7-rc-1 or 14.10.15.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2023-50721 being exploited?
There is no known exploitation of CVE-2023-50721 in the wild and no public exploit code.
Other vulnerabilities in Xwiki Xwiki
- CVE-2025-24893 XWiki Platform Eval Injection
- CVE-2025-53836 XWiki Rendering is vulnerable to RCE attacks when processing nested macros
- CVE-2024-55662 XWiki allows remote code execution through the extension sheet
- CVE-2024-55877 XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList
- CVE-2024-37901 XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet
Sources
Also known as GHSA-7654-vfh6-rw6x.