CVE-2023-50722 XWiki Platform XSS/CSRF Remote Code Execution in XWiki.ConfigurableClass
Attackers can achieve remote code execution by tricking admins into visiting a crafted URL, exploiting XSS and CSRF flaws in the configuration module.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2023-50722?
CVE-2023-50722 is a critical cross-site scripting vulnerability in Xwiki Xwiki, published on 15 Dec 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
XWiki Platform is a generic wiki platform. Starting in 2.3 and prior to versions 14.10.15, 15.5.2, and 15.7-rc-1, there is a reflected XSS or also direct remote code execution vulnerability in the code for displaying configurable admin sections. The code that can be passed through a URL parameter is only executed when the user who is visiting the crafted URL has edit right on at least one configuration section. While any user of the wiki could easily create such a section, this vulnerability doesn't require the attacker to have an account or any access on the wiki. It is sufficient to trick any admin user of the XWiki installation to visit the crafted URL. This vulnerability allows full remote code execution with programming rights and thus impacts the confidentiality, integrity and availability of the whole XWiki installation. This has been fixed in XWiki 14.10.15, 15.5.2 and 15.7RC1. The patch can be manually applied to the document `XWiki.ConfigurableClass`.
Which versions are affected by CVE-2023-50722?
6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-administration-ui. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.xwiki.platform:xwiki-platform-administration-ui Maven | From 15.0-rc-1 | 15.5.2 |
org.xwiki.platform:xwiki-platform-administration-ui Maven | From 15.0-rc-1 | 15.5.2 |
org.xwiki.platform:xwiki-platform-administration-ui Maven | From 15.6-rc-1 | 15.7-rc-1 |
org.xwiki.platform:xwiki-platform-administration-ui Maven | From 15.6-rc-1 | 15.7-rc-1 |
org.xwiki.platform:xwiki-platform-administration-ui Maven | From 2.3 | 14.10.15 |
org.xwiki.platform:xwiki-platform-administration-ui Maven | From 2.3 | 14.10.15 |
Products include Xwiki Xwiki.
How do I fix CVE-2023-50722?
Upgrade org.xwiki.platform:xwiki-platform-administration-ui to a fixed version for your release line: 15.5.2, 15.7-rc-1 or 14.10.15.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2023-50722 being exploited?
There is no known exploitation of CVE-2023-50722 in the wild and no public exploit code.
Other vulnerabilities in Xwiki Xwiki
- CVE-2025-24893 XWiki Platform Eval Injection
- CVE-2025-53836 XWiki Rendering is vulnerable to RCE attacks when processing nested macros
- CVE-2024-55662 XWiki allows remote code execution through the extension sheet
- CVE-2024-55877 XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList
- CVE-2024-37901 XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet
Sources
Also known as GHSA-cp3j-273x-3jxc.