# CVE-2023-50723: XWiki Platform remote code execution/programming rights with configuration section from any user account

> Attackers with edit rights can inject code via administration sections to gain programming rights and execute arbitrary code.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Dec 2023
- **Updated:** 7 May 2025
- **Also known as:** GHSA-qj86-p74r-7wp5

## What is CVE-2023-50723?

CVE-2023-50723 is a critical code injection vulnerability in Xwiki Xwiki, published on 15 Dec 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

XWiki Platform is a generic wiki platform. Starting in 2.3 and prior to versions 14.10.15, 15.5.2, and 15.7-rc-1, anyone who can edit an arbitrary wiki page in an XWiki installation can gain programming right through several cases of missing escaping in the code for displaying sections in the administration interface. This impacts the confidentiality, integrity and availability of the whole XWiki installation. Normally, all users are allowed to edit their own user profile so this should be exploitable by all users of the XWiki instance. This has been fixed in XWiki 14.10.15, 15.5.2 and 15.7RC1. The patches can be manually applied to the `XWiki.ConfigurableClassMacros` and `XWiki.ConfigurableClass` pages.

Weakness: CWE-95 (Improper Neutralization of Directives in Dynamically Evaluated Code), CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2023-50723?

6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-administration-ui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-administration-ui` | Maven | From 15.0-rc-1 | 15.5.2 |
| `org.xwiki.platform:xwiki-platform-administration-ui` | Maven | From 15.0-rc-1 | 15.5.2 |
| `org.xwiki.platform:xwiki-platform-administration-ui` | Maven | From 15.6-rc-1 | 15.7-rc-1 |
| `org.xwiki.platform:xwiki-platform-administration-ui` | Maven | From 15.6-rc-1 | 15.7-rc-1 |
| `org.xwiki.platform:xwiki-platform-administration-ui` | Maven | From 2.3 | 14.10.15 |
| `org.xwiki.platform:xwiki-platform-administration-ui` | Maven | From 2.3 | 14.10.15 |

Products: Xwiki Xwiki.

## How do I fix CVE-2023-50723?

Upgrade org.xwiki.platform:xwiki-platform-administration-ui to a fixed version for your release line: 15.5.2, 15.7-rc-1 or 14.10.15.

## Is CVE-2023-50723 being exploited?

There is no known exploitation of CVE-2023-50723 in the wild and no public exploit code.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-50723 and fix it if it is affected.

What it is: CVE-2023-50723 is a critical code injection vulnerability in Xwiki Xwiki, published on 15 Dec 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-50723 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-administration-ui (Maven): affected from 15.0-rc-1; fixed in 15.5.2
- org.xwiki.platform:xwiki-platform-administration-ui (Maven): affected from 15.0-rc-1; fixed in 15.5.2
- org.xwiki.platform:xwiki-platform-administration-ui (Maven): affected from 15.6-rc-1; fixed in 15.7-rc-1
- org.xwiki.platform:xwiki-platform-administration-ui (Maven): affected from 15.6-rc-1; fixed in 15.7-rc-1
- org.xwiki.platform:xwiki-platform-administration-ui (Maven): affected from 2.3; fixed in 14.10.15
- org.xwiki.platform:xwiki-platform-administration-ui (Maven): affected from 2.3; fixed in 14.10.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-50723/ (Markdown: https://insights.sbomify.com/CVE-2023-50723/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-50723
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-50723
- OSV: https://osv.dev/vulnerability/CVE-2023-50723

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-50723/
Summaries are generated and may contain mistakes; the official description above is the record.
