{"answers":{"affected":"2 open source packages ship an affected version, including resque. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-50724 in the wild and no public exploit code.","fix":"Upgrade resque to 2.1.0 or later.","what":"CVE-2023-50724 is a medium-severity cross-site scripting vulnerability in resque, published on 21 Dec 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-50724 and fix it if it is affected.\n\nWhat it is: CVE-2023-50724 is a medium-severity cross-site scripting vulnerability in resque, published on 21 Dec 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-50724 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- resque (RubyGems): affected all versions; fixed in 2.1.0\n- resque (RubyGems): affected all versions; fixed in 2.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-50724/ (Markdown: https://insights.sbomify.com/CVE-2023-50724/index.md)","id":"CVE-2023-50724","markdown":"https://insights.sbomify.com/CVE-2023-50724/index.md","name":"CVE-2023-50724","record":{"aliases":["GHSA-r8xx-8vm8-x6wj"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby background job library","requires_auth":"low_privilege","summary":"Reflected XSS in Resque web interface allows attackers to execute arbitrary scripts via the current_queue parameter.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"resque","vendor":"resque"}],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Resque (pronounced like \"rescue\") is a Redis-backed library for creating background jobs, placing those jobs on multiple queues, and processing them later. resque-web in resque versions before 2.1.0 are vulnerable to reflected XSS through the current_queue parameter in the path of the queues endpoint. This issue has been patched in version 2.1.0.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Resque vulnerable to reflected cross site scripting through pathname","id":"CVE-2023-50724","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"xss","year":"2023"},"n_packages":2,"n_references":3,"next":{"headline":"Resque vulnerable to reflected XSS in resque-web failed and queues lists","id":"CVE-2023-50725"},"packages":[{"ecosystem":"RubyGems","fixed":["2.1.0"],"introduced":["0"],"last_affected":[],"package":"resque","purl":null,"source":"GHSA-r8xx-8vm8-x6wj"},{"ecosystem":"RubyGems","fixed":["2.1.0"],"introduced":["0"],"last_affected":[],"package":"resque","purl":"pkg:gem/resque","source":"GHSA-r8xx-8vm8-x6wj"}],"prev":{"headline":"XWiki Platform remote code execution/programming rights with configuration section from any user account","id":"CVE-2023-50723"},"products":["resque"],"published":"2023-12-21","related":[{"cvss_score":6.3,"headline":"Resque vulnerable to reflected XSS in resque-web failed and queues lists","id":"CVE-2023-50725","kev_date_added":null,"published":"2023-12-22"},{"cvss_score":6.3,"headline":"Resque vulnerable to reflected XSS in Queue Endpoint","id":"CVE-2023-50727","kev_date_added":null,"published":"2023-12-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-27","vendors":["resque"]},"summary":"Reflected XSS in Resque web interface allows attackers to execute arbitrary scripts via the current_queue parameter.","url":"https://insights.sbomify.com/CVE-2023-50724/"}