# CVE-2023-50724: Resque vulnerable to reflected cross site scripting through pathname

> Reflected XSS in Resque web interface allows attackers to execute arbitrary scripts via the current_queue parameter.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Dec 2023
- **Updated:** 27 Aug 2024
- **Also known as:** GHSA-r8xx-8vm8-x6wj

## What is CVE-2023-50724?

CVE-2023-50724 is a medium-severity cross-site scripting vulnerability in resque, published on 21 Dec 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Resque (pronounced like "rescue") is a Redis-backed library for creating background jobs, placing those jobs on multiple queues, and processing them later. resque-web in resque versions before 2.1.0 are vulnerable to reflected XSS through the current_queue parameter in the path of the queues endpoint. This issue has been patched in version 2.1.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-50724?

2 open source packages ship an affected version, including resque. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `resque` | RubyGems | All versions | 2.1.0 |
| `resque` | RubyGems | All versions | 2.1.0 |

Products: Resque Resque.

## How do I fix CVE-2023-50724?

Upgrade resque to 2.1.0 or later.

## Is CVE-2023-50724 being exploited?

There is no known exploitation of CVE-2023-50724 in the wild and no public exploit code.

## Other vulnerabilities in resque

- [CVE-2023-50725](https://insights.sbomify.com/CVE-2023-50725/): Resque vulnerable to reflected XSS in resque-web failed and queues lists (medium 6.3)
- [CVE-2023-50727](https://insights.sbomify.com/CVE-2023-50727/): Resque vulnerable to reflected XSS in Queue Endpoint (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-50724 and fix it if it is affected.

What it is: CVE-2023-50724 is a medium-severity cross-site scripting vulnerability in resque, published on 21 Dec 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-50724 in the wild and no public exploit code.

Affected packages and fixed versions:
- resque (RubyGems): affected all versions; fixed in 2.1.0
- resque (RubyGems): affected all versions; fixed in 2.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-50724/ (Markdown: https://insights.sbomify.com/CVE-2023-50724/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-50724
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-50724
- OSV: https://osv.dev/vulnerability/CVE-2023-50724

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-50724/
Summaries are generated and may contain mistakes; the official description above is the record.
