{"answers":{"affected":"2 open source packages ship an affected version, including resque. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-50727 in the wild and no public exploit code.","fix":"Upgrade resque to 2.6.0 or later.","what":"CVE-2023-50727 is a medium-severity cross-site scripting vulnerability in resque, published on 22 Dec 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-50727 and fix it if it is affected.\n\nWhat it is: CVE-2023-50727 is a medium-severity cross-site scripting vulnerability in resque, published on 22 Dec 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-50727 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- resque (RubyGems): affected all versions; fixed in 2.6.0\n- resque (RubyGems): affected all versions; fixed in 2.6.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-50727/ (Markdown: https://insights.sbomify.com/CVE-2023-50727/index.md)","id":"CVE-2023-50727","markdown":"https://insights.sbomify.com/CVE-2023-50727/index.md","name":"CVE-2023-50727","record":{"aliases":["GHSA-r9mq-m72x-257g"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby background job library","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary JavaScript in the context of other users via a reflected XSS vulnerability in the Resque queue endpoint.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"resque","vendor":"resque"}],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Resque is a Redis-backed Ruby library for creating background jobs, placing them on multiple queues, and processing them later. Reflected XSS issue occurs when /queues is appended with /\"\u003e\u003csvg%20onload=alert(domain)\u003e. This issue has been patched in version 2.6.0.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Resque vulnerable to reflected XSS in Queue Endpoint","id":"CVE-2023-50727","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"xss","year":"2023"},"n_packages":2,"n_references":3,"next":{"headline":"Unauthenticated Denial of Service in the octokit/webhooks library","id":"CVE-2023-50728"},"packages":[{"ecosystem":"RubyGems","fixed":["2.6.0"],"introduced":["0"],"last_affected":[],"package":"resque","purl":null,"source":"GHSA-r9mq-m72x-257g"},{"ecosystem":"RubyGems","fixed":["2.6.0"],"introduced":["0"],"last_affected":[],"package":"resque","purl":"pkg:gem/resque","source":"GHSA-r9mq-m72x-257g"}],"prev":{"headline":"Users with `create` but not `override` privileges can perform local sync in argo-cd","id":"CVE-2023-50726"},"products":["resque"],"published":"2023-12-22","related":[{"cvss_score":6.3,"headline":"Resque vulnerable to reflected XSS in resque-web failed and queues lists","id":"CVE-2023-50725","kev_date_added":null,"published":"2023-12-22"},{"cvss_score":6.3,"headline":"Resque vulnerable to reflected cross site scripting through pathname","id":"CVE-2023-50724","kev_date_added":null,"published":"2023-12-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["resque"]},"summary":"Attackers can execute arbitrary JavaScript in the context of other users via a reflected XSS vulnerability in the Resque queue endpoint.","url":"https://insights.sbomify.com/CVE-2023-50727/"}