CVE-2023-50728 Unauthenticated Denial of Service in the octokit/webhooks library

Medium 5.4 Published Updated

An uncaught exception in the octokit/webhooks library allows unauthenticated attackers to crash the Node.js process, causing denial of service.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-50728?

CVE-2023-50728 is a medium-severity denial of service vulnerability in octokit webhooks.js, published on 15 Dec 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

Official description

octokit/webhooks is a GitHub webhook events toolset for Node.js. Starting in 9.26.0 and prior to 9.26.3, 10.9.2, 11.1.2, and 12.0.4, there is a problem caused by an issue with error handling in the @octokit/webhooks library because the error can be undefined in some cases. The resulting request was found to cause an uncaught exception that ends the nodejs process. The bug is fixed in octokit/webhooks.js 9.26.3, 10.9.2, 11.1.2, and 12.0.4, app.js 14.02, octokit.js 3.1.2, and Protobot 12.3.3.

Weakness: CWE-755

Which versions are affected by CVE-2023-50728?

14 open source packages ship an affected version, including @octokit/webhooks, @octokit/app and octokit. It affects 4 products.

PackageAffectedFixed in
@octokit/webhooks npmAll versions9.26.3
@octokit/webhooks npmAll versions9.26.3
@octokit/webhooks npmFrom 10.0.010.9.2
@octokit/webhooks npmFrom 10.0.010.9.2
@octokit/webhooks npmFrom 11.0.011.1.2
@octokit/webhooks npmFrom 11.0.011.1.2
8 more packages
@octokit/webhooks npmFrom 12.0.012.0.3
@octokit/webhooks npmFrom 12.0.012.0.3
@octokit/app npmFrom 14.0.114.0.2
@octokit/app npmFrom 14.0.114.0.2
octokit npmAll versions3.1.2
octokit npmAll versions3.1.2
probot npmAll versions12.3.3
probot npmAll versions12.3.3

Products include Octokit App, Octokit Octokit, Octokit Webhooks, Probot Probot.

How do I fix CVE-2023-50728?

Upgrade @octokit/webhooks to a fixed version for your release line: 9.26.3, 10.9.2, 11.1.2 or 12.0.3.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2023-50728 being exploited?

There is no known exploitation of CVE-2023-50728 in the wild and no public exploit code.

Sources

Also known as GHSA-pwfr-8pq7-x9qv.

Is CVE-2023-50728 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free