CVE-2023-5077 Vault's Google Cloud Secrets Engine Removed Existing IAM Conditions When Creating / Updating Rolesets

High 7.6 Published Updated

Attackers can bypass intended IAM restrictions because Vault's Google Cloud engine fails to preserve existing IAM conditions during roleset updates.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-5077?

CVE-2023-5077 is a high-severity missing authorization vulnerability in Hashicorp Vault, published on 28 Sep 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

The Vault and Vault Enterprise ("Vault") Google Cloud secrets engine did not preserve existing Google Cloud IAM Conditions upon creating or updating rolesets. Fixed in Vault 1.13.0.

Weakness: CWE-732, CWE-266

Which versions are affected by CVE-2023-5077?

4 open source packages ship an affected version, including github.com/hashicorp/vault and vault. It affects 1 product.

PackageAffectedFixed in
github.com/hashicorp/vault GoAll versions1.13.0
github.com/hashicorp/vault GoAll versions1.13.0
github.com/hashicorp/vault GoAll versions1.13.0
vault BitnamiFrom 0.10.01.13.0

Products include Hashicorp Vault.

How do I fix CVE-2023-5077?

Upgrade github.com/hashicorp/vault to 1.13.0 or later.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2023-5077 being exploited?

There is no known exploitation of CVE-2023-5077 in the wild and no public exploit code.

All Hashicorp Vault vulnerabilities

Sources

Also known as BIT-vault-2023-5077, GHSA-86c6-3g63-5w64, GO-2023-2088.

Is CVE-2023-5077 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free