# CVE-2023-50782: Python-cryptography: bleichenbacher timing oracle attack against rsa decryption - incomplete fix for cve-2020-25659

> A timing oracle in RSA decryption allows remote attackers to decrypt TLS messages, exposing sensitive data in applications using the library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Feb 2024
- **Updated:** 24 Mar 2026
- **Also known as:** AZL-34309, AZL-35129, BELL-CVE-2023-50782, DEBIAN-CVE-2023-50782, ECHO-96e2-b383-d2c5, GHSA-3ww4-gg4f-jr7f, MINI-x72j-7jwg-r8qc, OESA-2025-1774, OESA-2025-1775, OESA-2025-1776, OESA-2025-1863, OESA-2025-1864, OESA-2025-1865, PYSEC-2026-1283, ROOT-APP-PYPI-CVE-2023-50782, SUSE-SU-2024:3757-1, SUSE-SU-2024:3765-1, SUSE-SU-2024:3872-1, SUSE-SU-2024:3904-1, SUSE-SU-2024:3905-1, SUSE-SU-2024:3943-1, SUSE-SU-2025:20593-1, UBUNTU-CVE-2023-50782, USN-6663-1, USN-6673-2

## What is CVE-2023-50782?

CVE-2023-50782 is a high-severity vulnerability in Couchbase Couchbase Server, published on 5 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A flaw was found in the python-cryptography package. This issue may allow a remote attacker to decrypt captured messages in TLS servers that use RSA key exchanges, which may lead to exposure of confidential or sensitive data.

Weakness: CWE-203 (Observable Discrepancy)

## Which versions are affected by CVE-2023-50782?

3 open source packages ship an affected version, including cryptography. It affects 5 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cryptography` | PyPI | All versions | 42.0.0 |
| `cryptography` | PyPI | All versions | 42.0.0 |
| `cryptography` | PyPI | All versions | 42.0.0 |
| `openssl-1_1` | SUSE:Enterprise Storage 7.1 | All versions | 1.1.1d-150200.11.97.1 |
| `openssl-1_1` | SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS | All versions | 1.1.1d-150200.11.97.1 |
| `openssl-1_1` | SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS | All versions | 1.1.1d-150200.11.97.1 |
| `openssl-1_1` | SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 1.1.1l-150400.7.75.1 |
| `openssl-1_1` | SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 1.1.1l-150400.7.75.1 |
| `openssl-1_1` | SUSE:Linux Enterprise Micro 5.1 | All versions | 1.1.1d-150200.11.97.1 |
| `openssl-1_1` | SUSE:Linux Enterprise Micro 5.2 | All versions | 1.1.1d-150200.11.97.1 |
| `openssl-1_1` | SUSE:Linux Enterprise Micro 5.3 | All versions | 1.1.1l-150400.7.75.1 |
| `openssl-1_1` | SUSE:Linux Enterprise Micro 5.4 | All versions | 1.1.1l-150400.7.75.1 |
| `openssl-1_1` | SUSE:Linux Enterprise Micro 5.5 | All versions | 1.1.1l-150500.17.37.1 |
| `openssl-1_1` | SUSE:Linux Enterprise Module for Basesystem 15 SP5 | All versions | 1.1.1l-150500.17.37.1 |
| `openssl-1_1` | SUSE:Linux Enterprise Module for Basesystem 15 SP6 | All versions | 1.1.1w-150600.5.9.1 |
| `openssl-3` | SUSE:Linux Enterprise Module for Basesystem 15 SP6 | All versions | 3.1.4-150600.5.21.1 |
| `openssl-1_1` | SUSE:Linux Enterprise Module for Development Tools 15 SP6 | All versions | 1.1.1w-150600.5.9.1 |
| `openssl-1_1` | SUSE:Linux Enterprise Module for Legacy 15 SP6 | All versions | 1.1.1w-150600.5.9.1 |
| `openssl-1_1` | SUSE:Linux Enterprise Server 12 SP5-LTSS | All versions | 1.1.1d-2.113.1 |
| `openssl-1_1` | SUSE:Linux Enterprise Server 15 SP2-LTSS | All versions | 1.1.1d-150200.11.97.1 |
| `openssl-1_1` | SUSE:Linux Enterprise Server 15 SP3-LTSS | All versions | 1.1.1d-150200.11.97.1 |
| `openssl-1_1` | SUSE:Linux Enterprise Server 15 SP4-LTSS | All versions | 1.1.1l-150400.7.75.1 |
| `openssl-1_1` | SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5 | All versions | 1.1.1d-2.113.1 |
| `openssl-1_1` | SUSE:Linux Enterprise Server for SAP Applications 15 SP2 | All versions | 1.1.1d-150200.11.97.1 |
| `openssl-1_1` | SUSE:Linux Enterprise Server for SAP Applications 15 SP3 | All versions | 1.1.1d-150200.11.97.1 |
| `openssl-1_1` | SUSE:Linux Enterprise Server for SAP Applications 15 SP4 | All versions | 1.1.1l-150400.7.75.1 |
| `openssl-3` | SUSE:Linux Micro 6.1 | All versions | 3.1.4-slfo.1.1_6.1 |
| `openssl-1_1` | SUSE:Manager Server 4.3 | All versions | 1.1.1l-150400.7.75.1 |
| `openssl-1_1` | openSUSE:Leap 15.5 | All versions | 1.1.1l-150500.17.37.1 |
| `openssl-1_1` | openSUSE:Leap 15.6 | All versions | 1.1.1w-150600.5.9.1 |
| `openssl-3` | openSUSE:Leap 15.6 | All versions | 3.1.4-150600.5.21.1 |
| `openssl-1_1` | openSUSE:Leap Micro 5.5 | All versions | 1.1.1l-150500.17.37.1 |

Products: Couchbase Couchbase Server, Cryptography.io Cryptography, Redhat Ansible Automation Platform, Redhat Enterprise Linux, Redhat Update Infrastructure.

## How do I fix CVE-2023-50782?

Upgrade cryptography to 42.0.0 or later.

## Is CVE-2023-50782 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-50782 exists.

## Other vulnerabilities in Couchbase Couchbase Server

- [CVE-2024-0519](https://insights.sbomify.com/CVE-2024-0519/): Google Chromium V8 Out-of-Bounds Memory Access (high 8.8, exploited in the wild)
- [CVE-2023-3079](https://insights.sbomify.com/CVE-2023-3079/): Google Chromium V8 Type Confusion (high 8.8, exploited in the wild)
- [CVE-2023-2033](https://insights.sbomify.com/CVE-2023-2033/): Google Chromium V8 Type Confusion (high 8.8, exploited in the wild)
- [CVE-2023-49930](https://insights.sbomify.com/CVE-2023-49930/): Missing authorization in n/a (critical 9.8)
- [CVE-2023-49931](https://insights.sbomify.com/CVE-2023-49931/): Missing authorization in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-50782 and fix it if it is affected.

What it is: CVE-2023-50782 is a high-severity vulnerability in Couchbase Couchbase Server, published on 5 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-50782 exists.

Affected packages and fixed versions:
- cryptography (PyPI): affected all versions; fixed in 42.0.0
- cryptography (PyPI): affected all versions; fixed in 42.0.0
- cryptography (PyPI): affected all versions; fixed in 42.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-50782/ (Markdown: https://insights.sbomify.com/CVE-2023-50782/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-50782
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-50782
- OSV: https://osv.dev/vulnerability/CVE-2023-50782

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-50782/
Summaries are generated and may contain mistakes; the official description above is the record.
