# CVE-2023-50944: Apache Airflow: Bypass permission verification to read code of other dags

> Authenticated users can bypass permission checks to read the source code of DAGs they are not authorized to access.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Jan 2024
- **Updated:** 11 Jun 2025
- **Also known as:** BIT-airflow-2023-50944, ECHO-bb04-fbde-5d73, GHSA-vm5m-qmrx-fw8w, PYSEC-2024-14

## What is CVE-2023-50944?

CVE-2023-50944 is a medium-severity missing authorization vulnerability in Apache Airflow, published on 24 Jan 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Apache Airflow, versions before 2.8.1, have a vulnerability that allows an authenticated user to access the source code of a DAG to which they don't have access. This vulnerability is considered low since it requires an authenticated user to exploit it. Users are recommended to upgrade to version 2.8.1, which fixes this issue.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2023-50944?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | All versions | 2.8.1 |
| `apache-airflow` | PyPI | All versions | 2.8.1rc1 |
| `apache-airflow` | PyPI | All versions | 2.8.1rc1 |
| `airflow` | Bitnami | All versions | 2.8.1 |

Products: Apache Airflow.

## How do I fix CVE-2023-50944?

Upgrade apache-airflow to a fixed version for your release line: 2.8.1 or 2.8.1rc1.

## Is CVE-2023-50944 being exploited?

There is no known exploitation of CVE-2023-50944 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-50944 and fix it if it is affected.

What it is: CVE-2023-50944 is a medium-severity missing authorization vulnerability in Apache Airflow, published on 24 Jan 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-50944 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected all versions; fixed in 2.8.1
- apache-airflow (PyPI): affected all versions; fixed in 2.8.1rc1
- apache-airflow (PyPI): affected all versions; fixed in 2.8.1rc1
- airflow (Bitnami): affected all versions; fixed in 2.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-50944/ (Markdown: https://insights.sbomify.com/CVE-2023-50944/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-50944
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-50944
- OSV: https://osv.dev/vulnerability/CVE-2023-50944

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-50944/
Summaries are generated and may contain mistakes; the official description above is the record.
