# CVE-2023-50974: Apprite CLI makes Use of Hard-coded Credentials

> Local attackers can read Appwrite user credentials from the CLI configuration file due to insecure file permissions.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jan 2024
- **Updated:** 17 Jun 2025
- **Also known as:** GHSA-g777-crp9-m27g, PYSEC-2024-2

## What is CVE-2023-50974?

CVE-2023-50974 is a medium-severity vulnerability in n/a, published on 9 Jan 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

In Appwrite CLI before 3.0.0, when using the login command, the credentials of the Appwrite user are stored in a ~/.appwrite/prefs.json file with 0644 as UNIX permissions. Any user of the local system can access those credentials.

Weakness: CWE-798 (Use of Hard-coded Credentials)

## Which versions are affected by CVE-2023-50974?

5 open source packages ship an affected version, including appwrite and appwrite-cli. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `appwrite` | PyPI | All versions | 3.0.0 |
| `appwrite` | PyPI | All versions | 3.0.0 |
| `appwrite` | PyPI | All versions | 3.0.0 |
| `appwrite-cli` | npm | All versions | 3.0.0 |
| `appwrite-cli` | npm | All versions | 3.0.0 |

Products: Appwrite Command Line Interface.

## How do I fix CVE-2023-50974?

Upgrade appwrite to 3.0.0 or later.

## Is CVE-2023-50974 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-50974 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-50974 and fix it if it is affected.

What it is: CVE-2023-50974 is a medium-severity vulnerability in n/a, published on 9 Jan 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-50974 exists.

Affected packages and fixed versions:
- appwrite (PyPI): affected all versions; fixed in 3.0.0
- appwrite (PyPI): affected all versions; fixed in 3.0.0
- appwrite (PyPI): affected all versions; fixed in 3.0.0
- appwrite-cli (npm): affected all versions; fixed in 3.0.0
- appwrite-cli (npm): affected all versions; fixed in 3.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-50974/ (Markdown: https://insights.sbomify.com/CVE-2023-50974/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-50974
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-50974
- OSV: https://osv.dev/vulnerability/CVE-2023-50974

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-50974/
Summaries are generated and may contain mistakes; the official description above is the record.
