# CVE-2023-5104: Improper Input Validation in nocodb/nocodb

> Improper input validation in NocoDB allows attackers to potentially cause unexpected behavior or errors.

- **Severity:** Medium 5.7 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Sep 2023
- **Updated:** 24 Sep 2024
- **Also known as:** GHSA-xrpm-hccg-28x7

## What is CVE-2023-5104?

CVE-2023-5104 is a medium-severity vulnerability in nocodb/nocodb, published on 21 Sep 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Improper Input Validation in GitHub repository nocodb/nocodb prior to 0.96.0.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2023-5104?

2 open source packages ship an affected version, including nocodb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nocodb` | npm | All versions | 0.96.0 |
| `nocodb` | npm | All versions | 0.96.0 |

Products: Nocodb Nocodb.

## How do I fix CVE-2023-5104?

Upgrade nocodb to 0.96.0 or later.

## Is CVE-2023-5104 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-5104 exists.

## Other vulnerabilities in nocodb/nocodb

- [CVE-2022-2339](https://insights.sbomify.com/CVE-2022-2339/): Server-Side Request Forgery (SSRF) in nocodb/nocodb (critical 9.1)
- [CVE-2022-2062](https://insights.sbomify.com/CVE-2022-2062/): Generation of Error Message Containing Sensitive Information in nocodb/nocodb (critical 9.1)
- [CVE-2022-2064](https://insights.sbomify.com/CVE-2022-2064/): Insufficient Session Expiration in nocodb/nocodb (critical 9.1)
- [CVE-2022-2063](https://insights.sbomify.com/CVE-2022-2063/): Improper Privilege Management in nocodb/nocodb (critical 9.0)
- [CVE-2022-2022](https://insights.sbomify.com/CVE-2022-2022/): Cross-site Scripting (XSS) - Stored in nocodb/nocodb (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-5104 and fix it if it is affected.

What it is: CVE-2023-5104 is a medium-severity vulnerability in nocodb/nocodb, published on 21 Sep 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-5104 exists.

Affected packages and fixed versions:
- nocodb (npm): affected all versions; fixed in 0.96.0
- nocodb (npm): affected all versions; fixed in 0.96.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-5104/ (Markdown: https://insights.sbomify.com/CVE-2023-5104/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-5104
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-5104
- OSV: https://osv.dev/vulnerability/CVE-2023-5104

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-5104/
Summaries are generated and may contain mistakes; the official description above is the record.
