CVE-2023-5106 Incorrect Authorization in GitLab

High 8.2 Published Updated

Attackers can impersonate users in CI pipelines via group imports, potentially leading to privilege escalation and code execution.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-5106?

CVE-2023-5106 is a high-severity missing authorization vulnerability in Gitlab Gitlab, published on 2 Oct 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue has been discovered in Ultimate-licensed GitLab EE affecting all versions starting 13.12 prior to 16.2.8, 16.3.0 prior to 16.3.5, and 16.4.0 prior to 16.4.1 that could allow an attacker to impersonate users in CI pipelines through direct transfer group imports.

Weakness: CWE-863

Which versions are affected by CVE-2023-5106?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 13.12.016.2.8, 16.3.5, 16.4.1

Products include Gitlab Gitlab.

How do I fix CVE-2023-5106?

Upgrade gitlab to a fixed version for your release line: 16.2.8, 16.3.5 or 16.4.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2023-5106 being exploited?

There is no known exploitation of CVE-2023-5106 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2023-5106, GHSA-chxc-x49q-7m83, UBUNTU-CVE-2023-5106.

Is CVE-2023-5106 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free