{"answers":{"affected":"2 open source packages ship an affected version, including com.jayway.jsonpath:json-path. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-51074 in the wild and no public exploit code.","fix":"Upgrade com.jayway.jsonpath:json-path to 2.9.0 or later.","what":"CVE-2023-51074 is a medium-severity denial of service vulnerability in n/a, published on 27 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-51074 and fix it if it is affected.\n\nWhat it is: CVE-2023-51074 is a medium-severity denial of service vulnerability in n/a, published on 27 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-51074 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.jayway.jsonpath:json-path (Maven): affected from 2.2.0; fixed in 2.9.0\n- com.jayway.jsonpath:json-path (Maven): affected from 2.2.0; fixed in 2.9.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-51074/ (Markdown: https://insights.sbomify.com/CVE-2023-51074/index.md)","id":"CVE-2023-51074","markdown":"https://insights.sbomify.com/CVE-2023-51074/index.md","name":"CVE-2023-51074","record":{"aliases":["CLSA-2026-1788766643","CLSA-2026-1788767433","CLSA-2026-1788853239","CLSA-2026-1788853251","CLSA-2026-1788853304","CLSA-2026-1789382508","GHSA-pfh2-hfmq-phg5","OESA-2024-1252","RHLW-2026-a4c4a4bf58e29184","RHLW-2026-f8f17f4598510b8d","ROOT-APP-MAVEN-CVE-2023-51074","UBUNTU-CVE-2023-51074"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Java JSON path library","requires_auth":"none","summary":"A stack overflow in the Criteria.parse method allows attackers to cause a denial of service in applications using the json-path library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"jayway_jsonpath","vendor":"json-path"}],"cvss":{"score":5.3,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[],"description":"json-path v2.8.0 was discovered to contain a stack overflow via the Criteria.parse() method.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"json-path Out-of-bounds Write vulnerability","id":"CVE-2023-51074","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":2,"n_references":1,"next":{"headline":"hutool-core discovered to contain an infinite loop in the StrSplitter.splitByRegex function","id":"CVE-2023-51075"},"packages":[{"ecosystem":"Maven","fixed":["2.9.0"],"introduced":["2.2.0"],"last_affected":[],"package":"com.jayway.jsonpath:json-path","purl":null,"source":"GHSA-pfh2-hfmq-phg5"},{"ecosystem":"Maven","fixed":["2.9.0"],"introduced":["2.2.0"],"last_affected":[],"package":"com.jayway.jsonpath:json-path","purl":"pkg:maven/com.jayway.jsonpath/json-path","source":"GHSA-pfh2-hfmq-phg5"}],"prev":{"headline":"Command injection in n/a","id":"CVE-2023-51073"},"products":["n/a"],"published":"2023-12-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-02","vendors":["n/a"]},"summary":"A stack overflow in the Criteria.parse method allows attackers to cause a denial of service in applications using the json-path library.","url":"https://insights.sbomify.com/CVE-2023-51074/"}