# CVE-2023-5115: Ansible: malicious role archive can cause ansible-galaxy to overwrite arbitrary files

> Attackers can craft malicious Ansible roles to overwrite arbitrary files on the victim's system via symlink-based path traversal during role installation.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Dec 2023
- **Updated:** 20 Nov 2025
- **Also known as:** AZL-32279, AZL-34540, DEBIAN-CVE-2023-5115, GHSA-jpvw-p8pr-9g2x, PYSEC-2026-1120, UBUNTU-CVE-2023-5115, openSUSE-SU-2024:13311-1

## What is CVE-2023-5115?

CVE-2023-5115 is a medium-severity path traversal vulnerability in Debian Debian Linux, published on 18 Dec 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

An absolute path traversal attack exists in the Ansible automation platform. This flaw allows an attacker to craft a malicious Ansible role and make the victim execute the role. A symlink can be used to overwrite a file outside of the extraction path.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory), CWE-36 (Absolute Path Traversal)

## Which versions are affected by CVE-2023-5115?

3 open source packages ship an affected version, including ansible. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ansible` | PyPI | All versions | 8.5.0 |
| `ansible` | PyPI | All versions | 8.5.0 |
| `ansible` | PyPI | All versions | 8.5.0 |

Products: Debian Debian Linux, Redhat Ansible Automation Platform, Redhat Ansible Developer, Redhat Ansible Inside.

## How do I fix CVE-2023-5115?

Upgrade ansible to 8.5.0 or later.

## Is CVE-2023-5115 being exploited?

There is no known exploitation of CVE-2023-5115 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-5115 and fix it if it is affected.

What it is: CVE-2023-5115 is a medium-severity path traversal vulnerability in Debian Debian Linux, published on 18 Dec 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-5115 in the wild and no public exploit code.

Affected packages and fixed versions:
- ansible (PyPI): affected all versions; fixed in 8.5.0
- ansible (PyPI): affected all versions; fixed in 8.5.0
- ansible (PyPI): affected all versions; fixed in 8.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-5115/ (Markdown: https://insights.sbomify.com/CVE-2023-5115/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-5115
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-5115
- OSV: https://osv.dev/vulnerability/CVE-2023-5115

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-5115/
Summaries are generated and may contain mistakes; the official description above is the record.
