# CVE-2023-51232: Dagster vulnerable to Path Traversal attack through its /logs endpoint

> Remote attackers can read sensitive files via crafted requests to the logs endpoint in Dagster webserver.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jul 2025
- **Updated:** 8 Jul 2025
- **Also known as:** GHSA-q93c-p2mw-p23f, PYSEC-2026-1287

## What is CVE-2023-51232?

CVE-2023-51232 is a high-severity path traversal vulnerability in n/a, published on 7 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Directory Traversal vulnerability in dagster-webserver Dagster thru 1.5.11 allows remote attackers to obtain sensitive information via crafted request to the /logs endpoint. This may be restricted to certain file names that start with a dot ('.').

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2023-51232?

3 open source packages ship an affected version, including dagster.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dagster` | PyPI | All versions | 1.5.11 |
| `dagster` | PyPI | All versions | 1.5.11 |
| `dagster` | PyPI | All versions | 1.5.11 |

## How do I fix CVE-2023-51232?

Upgrade dagster to 1.5.11 or later.

## Is CVE-2023-51232 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-51232 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-51232 and fix it if it is affected.

What it is: CVE-2023-51232 is a high-severity path traversal vulnerability in n/a, published on 7 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-51232 exists.

Affected packages and fixed versions:
- dagster (PyPI): affected all versions; fixed in 1.5.11
- dagster (PyPI): affected all versions; fixed in 1.5.11
- dagster (PyPI): affected all versions; fixed in 1.5.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-51232/ (Markdown: https://insights.sbomify.com/CVE-2023-51232/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-51232
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-51232
- OSV: https://osv.dev/vulnerability/CVE-2023-51232

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-51232/
Summaries are generated and may contain mistakes; the official description above is the record.
