# CVE-2023-51437: Apache Pulsar: Timing attack in SASL token signature verification

> Attackers can exploit timing discrepancies in SASL token verification to forge valid tokens, bypassing authentication in Apache Pulsar.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Feb 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-c57v-4vg5-cm2x

## What is CVE-2023-51437?

CVE-2023-51437 is a high-severity vulnerability in Apache Pulsar, published on 7 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Observable timing discrepancy vulnerability in Apache Pulsar SASL Authentication Provider can allow an attacker to forge a SASL Role Token that will pass signature verification.
Users are recommended to upgrade to version 2.11.3, 3.0.2, or 3.1.1 which fixes the issue. Users should also consider updating the configured secret in the `saslJaasServerRoleTokenSignerSecretPath` file.

Any component matching an above version running the SASL Authentication Provider is affected. That includes the Pulsar Broker, Proxy, Websocket Proxy, or Function Worker.

2.11 Pulsar users should upgrade to at least 2.11.3.
3.0 Pulsar users should upgrade to at least 3.0.2.
3.1 Pulsar users should upgrade to at least 3.1.1.
Any users running Pulsar 2.8, 2.9, 2.10, and earlier should upgrade to one of the above patched versions.

For additional details on this attack vector, please refer to  https://codahale.com/a-lesson-in-timing-attacks/ .

Weakness: CWE-203 (Observable Discrepancy)

## Which versions are affected by CVE-2023-51437?

6 open source packages ship an affected version, including org.apache.pulsar:pulsar-broker-auth-sasl. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.pulsar:pulsar-broker-auth-sasl` | Maven | All versions | 2.11.3 |
| `org.apache.pulsar:pulsar-broker-auth-sasl` | Maven | All versions | 2.11.3 |
| `org.apache.pulsar:pulsar-broker-auth-sasl` | Maven | From 3.0.0 | 3.0.2 |
| `org.apache.pulsar:pulsar-broker-auth-sasl` | Maven | From 3.0.0 | 3.0.2 |
| `org.apache.pulsar:pulsar-broker-auth-sasl` | Maven | From 3.1.0 | 3.1.1 |
| `org.apache.pulsar:pulsar-broker-auth-sasl` | Maven | From 3.1.0 | 3.1.1 |

Products: Apache Pulsar.

## How do I fix CVE-2023-51437?

Upgrade org.apache.pulsar:pulsar-broker-auth-sasl to a fixed version for your release line: 2.11.3, 3.0.2 or 3.1.1.

## Is CVE-2023-51437 being exploited?

There is no known exploitation of CVE-2023-51437 in the wild and no public exploit code.

## Other vulnerabilities in Apache Pulsar

- [CVE-2021-22160](https://insights.sbomify.com/CVE-2021-22160/): Authentication with JWT allows use of “none”-algorithm (critical 9.8)
- [CVE-2023-30429](https://insights.sbomify.com/CVE-2023-30429/): Apache Pulsar: Incorrect Authorization for Function Worker when using mTLS Authentication through Pulsar Proxy (critical 9.6)
- [CVE-2024-27135](https://insights.sbomify.com/CVE-2024-27135/): Apache Pulsar: Improper Input Validation in Pulsar Function Worker allows Remote Code Execution (high 8.5)
- [CVE-2024-27894](https://insights.sbomify.com/CVE-2024-27894/): Apache Pulsar: Pulsar Functions Worker Allows Unauthorized File Access and Unauthorized HTTP/HTTPS Proxying (high 8.5)
- [CVE-2024-27317](https://insights.sbomify.com/CVE-2024-27317/): Apache Pulsar: Pulsar Functions Worker's Archive Extraction Vulnerability Allows Unauthorized File Modification (high 8.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-51437 and fix it if it is affected.

What it is: CVE-2023-51437 is a high-severity vulnerability in Apache Pulsar, published on 7 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-51437 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.pulsar:pulsar-broker-auth-sasl (Maven): affected all versions; fixed in 2.11.3
- org.apache.pulsar:pulsar-broker-auth-sasl (Maven): affected all versions; fixed in 2.11.3
- org.apache.pulsar:pulsar-broker-auth-sasl (Maven): affected from 3.0.0; fixed in 3.0.2
- org.apache.pulsar:pulsar-broker-auth-sasl (Maven): affected from 3.0.0; fixed in 3.0.2
- org.apache.pulsar:pulsar-broker-auth-sasl (Maven): affected from 3.1.0; fixed in 3.1.1
- org.apache.pulsar:pulsar-broker-auth-sasl (Maven): affected from 3.1.0; fixed in 3.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-51437/ (Markdown: https://insights.sbomify.com/CVE-2023-51437/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-51437
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-51437
- OSV: https://osv.dev/vulnerability/CVE-2023-51437

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-51437/
Summaries are generated and may contain mistakes; the official description above is the record.
