# CVE-2023-51442: Authentication bypass vulnerability in navidrome's subsonic endpoint

> Attacker can bypass authentication in Navidrome's Subsonic endpoint using a hardcoded JWT key, gaining unauthorized access to user accounts and data.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Dec 2023
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-wq59-4q6r-635r, GO-2023-2414

## What is CVE-2023-51442?

CVE-2023-51442 is a high-severity authentication bypass vulnerability in navidrome, published on 21 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Navidrome is an open source web-based music collection server and streamer. A security vulnerability has been identified in navidrome's subsonic endpoint, allowing for authentication bypass. This exploit enables unauthorized access to any known account by utilizing a JSON Web Token (JWT) signed with the key "not so secret". The vulnerability can only be exploited on instances that have never been restarted. Navidrome supports an extension to the subsonic authentication scheme, where a JWT can be provided using a `jwt` query parameter instead of the traditional password or token and salt (corresponding to resp. the `p` or `t` and `s` query parameters). This authentication bypass vulnerability potentially affects all instances that don't protect the subsonic endpoint `/rest/`, which is expected to be most instances in a standard deployment, and most instances in the reverse proxy setup too (as the documentation mentions to leave that endpoint unprotected). This issue has been patched in version 0.50.2.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2023-51442?

3 open source packages ship an affected version, including github.com/navidrome/navidrome. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/navidrome/navidrome` | Go | All versions | 0.50.2 |
| `github.com/navidrome/navidrome` | Go | All versions | 0.50.2 |
| `github.com/navidrome/navidrome` | Go | All versions | 0.50.2 |

Products: Navidrome Navidrome.

## How do I fix CVE-2023-51442?

Upgrade github.com/navidrome/navidrome to 0.50.2 or later.

## Is CVE-2023-51442 being exploited?

There is no known exploitation of CVE-2023-51442 in the wild and no public exploit code.

## Other vulnerabilities in navidrome

- [CVE-2024-47062](https://insights.sbomify.com/CVE-2024-47062/): Multiple SQL Injections and ORM Leak in navidrome (critical 9.4)
- [CVE-2026-25579](https://insights.sbomify.com/CVE-2026-25579/): Navidrome affected by Denial of Service and disk exhaustion via oversized `size` parameter in `/rest/getCoverArt` and `/share/img/<token>` endpoints (critical 9.2)
- [CVE-2024-41259](https://insights.sbomify.com/CVE-2024-41259/): Navidrome uses MD5 hashing algorithm (critical 9.1)
- [CVE-2025-48949](https://insights.sbomify.com/CVE-2025-48949/): Navidrome allows SQL Injection via role parameter (high 8.9)
- [CVE-2025-48948](https://insights.sbomify.com/CVE-2025-48948/): Navidrome Transcoding Permission Bypass Vulnerability Report (high 7.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-51442 and fix it if it is affected.

What it is: CVE-2023-51442 is a high-severity authentication bypass vulnerability in navidrome, published on 21 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-51442 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/navidrome/navidrome (Go): affected all versions; fixed in 0.50.2
- github.com/navidrome/navidrome (Go): affected all versions; fixed in 0.50.2
- github.com/navidrome/navidrome (Go): affected all versions; fixed in 0.50.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-51442/ (Markdown: https://insights.sbomify.com/CVE-2023-51442/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-51442
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-51442
- OSV: https://osv.dev/vulnerability/CVE-2023-51442

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-51442/
Summaries are generated and may contain mistakes; the official description above is the record.
