CVE-2023-51444 GeoServer arbitrary file upload vulnerability in REST Coverage Store API
Authenticated administrators can upload arbitrary files to arbitrary locations via the REST API, leading to remote code execution or privilege escalation.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-51444?
CVE-2023-51444 is a high-severity vulnerability in geoserver, published on 20 Mar 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
GeoServer is an open source software server written in Java that allows users to share and edit geospatial data. An arbitrary file upload vulnerability exists in versions prior to 2.23.4 and 2.24.1 that enables an authenticated administrator with permissions to modify coverage stores through the REST Coverage Store API to upload arbitrary file contents to arbitrary file locations which can lead to remote code execution. Coverage stores that are configured using relative paths use a GeoServer Resource implementation that has validation to prevent path traversal but coverage stores that are configured using absolute paths use a different Resource implementation that does not prevent path traversal. This vulnerability can lead to executing arbitrary code. An administrator with limited privileges could also potentially exploit this to overwrite GeoServer security files and obtain full administrator privileges. Versions 2.23.4 and 2.24.1 contain a fix for this issue.
Which versions are affected by CVE-2023-51444?
8 open source packages ship an affected version, including org.geoserver:gs-platform and org.geoserver:gs-restconfig. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.geoserver:gs-platform Maven | All versions | 2.23.4 |
org.geoserver:gs-platform Maven | All versions | 2.23.4 |
org.geoserver:gs-platform Maven | From 2.24.0 | 2.24.1 |
org.geoserver:gs-platform Maven | From 2.24.0 | 2.24.1 |
org.geoserver:gs-restconfig Maven | All versions | 2.23.4 |
org.geoserver:gs-restconfig Maven | All versions | 2.23.4 |
2 more packages
org.geoserver:gs-restconfig Maven | From 2.24.0 | 2.24.1 |
org.geoserver:gs-restconfig Maven | From 2.24.0 | 2.24.1 |
Products include Geoserver Geoserver.
How do I fix CVE-2023-51444?
Upgrade org.geoserver:gs-platform to a fixed version for your release line: 2.23.4 or 2.24.1.
Is CVE-2023-51444 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-51444 exists.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in geoserver
- CVE-2024-36401 OSGeo GeoServer GeoTools Eval Injection
- CVE-2025-58360 OSGeo GeoServer Improper Restriction of XML External Entity Reference
- CVE-2023-35042 GeoServer RCE due to improper control of generation of code in jai-ext`Jiffle` map algebra language
- CVE-2024-24749 Classpath resource disclosure in GWC Web Resource API on Windows / Tomcat
- CVE-2023-41877 GeoServer log file path traversal vulnerability
Sources
Also known as GHSA-9v5q-2gwq-q9hq.