{"answers":{"affected":"4 open source packages ship an affected version, including decidim and decidim-core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-51447 in the wild and no public exploit code.","fix":"Upgrade decidim to 0.27.5 or later.","what":"CVE-2023-51447 is a medium-severity cross-site scripting vulnerability in decidim, published on 20 Feb 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-51447 and fix it if it is affected.\n\nWhat it is: CVE-2023-51447 is a medium-severity cross-site scripting vulnerability in decidim, published on 20 Feb 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-51447 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- decidim (RubyGems): affected from 0.27.0; fixed in 0.27.5\n- decidim (RubyGems): affected from 0.27.0; fixed in 0.27.5\n- decidim-core (RubyGems): affected from 0.27.0; fixed in 0.27.5\n- decidim-core (RubyGems): affected from 0.27.0; fixed in 0.27.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-51447/ (Markdown: https://insights.sbomify.com/CVE-2023-51447/index.md)","id":"CVE-2023-51447","markdown":"https://insights.sbomify.com/CVE-2023-51447/index.md","name":"CVE-2023-51447","record":{"aliases":["GHSA-9w99-78rj-hmxq"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Decidim participatory democracy framework","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary scripts via malicious file names in dynamic uploads, requiring session control and user interaction.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"decidim","vendor":"decidim"}],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Decidim is a participatory democracy framework. Starting in version 0.27.0 and prior to versions 0.27.5 and 0.28.0, the dynamic file upload feature is subject to potential cross-site scripting attacks in case the attacker manages to modify the file names of the records being uploaded to the server. This appears in sections where the user controls the file upload dialogs themselves and has the technical knowledge to change the file names through the dynamic upload endpoint. Therefore I believe it would require the attacker to control the whole session of the particular user but in any case, this needs to be fixed. Successful exploit of this vulnerability would require the user to have successfully uploaded a file blob to the server with a malicious file name and then have the possibility to direct the other user to the edit page of the record where the attachment is attached. The users are able to craft the direct upload requests themselves controlling the file name that gets stored to the database. The attacker is able to change the filename e.g. to `\u003csvg onload=alert('XSS')\u003e` if they know how to craft these requests themselves. And then enter the returned blob ID to the form inputs manually by modifying the edit page source. Versions 0.27.5 and 0.28.0 contain a patch for this issue. As a workaround, disable dynamic uploads for the instance, e.g. from proposals.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Decidim vulnerable to cross-site scripting (XSS) in the dynamic file uploads","id":"CVE-2023-51447","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"xss","year":"2023"},"n_packages":4,"n_references":6,"next":{"headline":"SQL Injection vulnerability when managing SNMP Notification Receivers","id":"CVE-2023-51448"},"packages":[{"ecosystem":"RubyGems","fixed":["0.27.5"],"introduced":["0.27.0"],"last_affected":[],"package":"decidim","purl":null,"source":"GHSA-9w99-78rj-hmxq"},{"ecosystem":"RubyGems","fixed":["0.27.5"],"introduced":["0.27.0"],"last_affected":[],"package":"decidim","purl":"pkg:gem/decidim","source":"GHSA-9w99-78rj-hmxq"},{"ecosystem":"RubyGems","fixed":["0.27.5"],"introduced":["0.27.0"],"last_affected":[],"package":"decidim-core","purl":null,"source":"GHSA-9w99-78rj-hmxq"},{"ecosystem":"RubyGems","fixed":["0.27.5"],"introduced":["0.27.0"],"last_affected":[],"package":"decidim-core","purl":"pkg:gem/decidim-core","source":"GHSA-9w99-78rj-hmxq"}],"prev":{"headline":"GLPI LDAP Injection during authentication","id":"CVE-2023-51446"},"products":["decidim"],"published":"2024-02-20","related":[{"cvss_score":9.3,"headline":"Decidim has a Cross-site scripting (XSS) vulnerability via user name field","id":"CVE-2026-23891","kev_date_added":null,"published":"2026-04-13"},{"cvss_score":9.1,"headline":"Decidim has broken access control in templates","id":"CVE-2023-36465","kev_date_added":null,"published":"2023-10-06"},{"cvss_score":8.2,"headline":"Decidim's private data exports can lead to data leaks","id":"CVE-2025-65017","kev_date_added":null,"published":"2026-02-03"},{"cvss_score":8.1,"headline":"Decidim Cross-site Scripting vulnerability in the external link redirections","id":"CVE-2023-32693","kev_date_added":null,"published":"2023-07-11"},{"cvss_score":8.1,"headline":"Decidim Cross-site Scripting vulnerability in the processes filter","id":"CVE-2023-34089","kev_date_added":null,"published":"2023-07-11"},{"cvss_score":7.7,"headline":"Decidim allows cross-site scripting (XSS) in the online or hybrid meeting embeds","id":"CVE-2024-45594","kev_date_added":null,"published":"2024-11-13"},{"cvss_score":7.5,"headline":"Decidim amendments can be accepted or rejected by anyone","id":"CVE-2026-40869","kev_date_added":null,"published":"2026-04-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-08-26","vendors":["decidim"]},"summary":"Attackers can execute arbitrary scripts via malicious file names in dynamic uploads, requiring session control and user interaction.","url":"https://insights.sbomify.com/CVE-2023-51447/"}