# CVE-2023-51447: Decidim vulnerable to cross-site scripting (XSS) in the dynamic file uploads

> Attackers can execute arbitrary scripts via malicious file names in dynamic uploads, requiring session control and user interaction.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Feb 2024
- **Updated:** 26 Aug 2024
- **Also known as:** GHSA-9w99-78rj-hmxq

## What is CVE-2023-51447?

CVE-2023-51447 is a medium-severity cross-site scripting vulnerability in decidim, published on 20 Feb 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Decidim is a participatory democracy framework. Starting in version 0.27.0 and prior to versions 0.27.5 and 0.28.0, the dynamic file upload feature is subject to potential cross-site scripting attacks in case the attacker manages to modify the file names of the records being uploaded to the server. This appears in sections where the user controls the file upload dialogs themselves and has the technical knowledge to change the file names through the dynamic upload endpoint. Therefore I believe it would require the attacker to control the whole session of the particular user but in any case, this needs to be fixed. Successful exploit of this vulnerability would require the user to have successfully uploaded a file blob to the server with a malicious file name and then have the possibility to direct the other user to the edit page of the record where the attachment is attached. The users are able to craft the direct upload requests themselves controlling the file name that gets stored to the database. The attacker is able to change the filename e.g. to `<svg onload=alert('XSS')>` if they know how to craft these requests themselves. And then enter the returned blob ID to the form inputs manually by modifying the edit page source. Versions 0.27.5 and 0.28.0 contain a patch for this issue. As a workaround, disable dynamic uploads for the instance, e.g. from proposals.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-51447?

4 open source packages ship an affected version, including decidim and decidim-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `decidim` | RubyGems | From 0.27.0 | 0.27.5 |
| `decidim` | RubyGems | From 0.27.0 | 0.27.5 |
| `decidim-core` | RubyGems | From 0.27.0 | 0.27.5 |
| `decidim-core` | RubyGems | From 0.27.0 | 0.27.5 |

Products: Decidim Decidim.

## How do I fix CVE-2023-51447?

Upgrade decidim to 0.27.5 or later.

## Is CVE-2023-51447 being exploited?

There is no known exploitation of CVE-2023-51447 in the wild and no public exploit code.

## Other vulnerabilities in decidim

- [CVE-2026-23891](https://insights.sbomify.com/CVE-2026-23891/): Decidim has a Cross-site scripting (XSS) vulnerability via user name field (critical 9.3)
- [CVE-2023-36465](https://insights.sbomify.com/CVE-2023-36465/): Decidim has broken access control in templates (critical 9.1)
- [CVE-2025-65017](https://insights.sbomify.com/CVE-2025-65017/): Decidim's private data exports can lead to data leaks (high 8.2)
- [CVE-2023-32693](https://insights.sbomify.com/CVE-2023-32693/): Decidim Cross-site Scripting vulnerability in the external link redirections (high 8.1)
- [CVE-2023-34089](https://insights.sbomify.com/CVE-2023-34089/): Decidim Cross-site Scripting vulnerability in the processes filter (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-51447 and fix it if it is affected.

What it is: CVE-2023-51447 is a medium-severity cross-site scripting vulnerability in decidim, published on 20 Feb 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-51447 in the wild and no public exploit code.

Affected packages and fixed versions:
- decidim (RubyGems): affected from 0.27.0; fixed in 0.27.5
- decidim (RubyGems): affected from 0.27.0; fixed in 0.27.5
- decidim-core (RubyGems): affected from 0.27.0; fixed in 0.27.5
- decidim-core (RubyGems): affected from 0.27.0; fixed in 0.27.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-51447/ (Markdown: https://insights.sbomify.com/CVE-2023-51447/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-51447
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-51447
- OSV: https://osv.dev/vulnerability/CVE-2023-51447

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-51447/
Summaries are generated and may contain mistakes; the official description above is the record.
