CVE-2023-51451 SSRF in symbolicator via invalid protocol
An attacker can force Symbolicator to send requests to internal IPs and expose responses via the API, requiring an upgrade to fix.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2023-51451?
CVE-2023-51451 is a medium-severity server-side request forgery vulnerability in getsentry symbolicator, published on 22 Dec 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Symbolicator is a service used in Sentry. Starting in Symbolicator version 0.3.3 and prior to version 21.12.1, an attacker could make Symbolicator send GET HTTP requests to arbitrary URLs with internal IP addresses by using an invalid protocol. The responses of those requests could be exposed via Symbolicator's API. In affected Sentry instances, the data could be exposed through the Sentry API and user interface if the attacker has a registered account. The issue has been fixed in Symbolicator release 23.12.1, Sentry self-hosted release 23.12.1, and has already been mitigated on sentry.io on December 18, 2023. If updating is not possible, some other mitigations are available. One may disable JS processing by toggling the option `Allow JavaScript Source Fetching` in `Organization Settings > Security & Privacy` and/or disable all untrusted public repositories under `Project Settings > Debug Files`. Alternatively, if JavaScript and native symbolication are not required, disable Symbolicator completely in `config.yml`.
Weakness: CWE-918
Which versions are affected by CVE-2023-51451?
It affects 1 product.
Products include Sentry Symbolicator.
How do I fix CVE-2023-51451?
No fix has been published for CVE-2023-51451 yet. Limit exposure of the affected software until one is available.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2023-51451 being exploited?
There is no known exploitation of CVE-2023-51451 in the wild and no public exploit code.
Other vulnerabilities in getsentry symbolicator
Sources
Also known as GHSA-ghg9-7m82-h96r.