{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-51451 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2023-51451 yet. Limit exposure of the affected software until one is available.","what":"CVE-2023-51451 is a medium-severity server-side request forgery vulnerability in getsentry symbolicator, published on 22 Dec 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-51451 and fix it if it is affected.\n\nWhat it is: CVE-2023-51451 is a medium-severity server-side request forgery vulnerability in getsentry symbolicator, published on 22 Dec 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-51451 in the wild and no public exploit code.\n\nAffected product: getsentry symbolicator. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-51451/ (Markdown: https://insights.sbomify.com/CVE-2023-51451/index.md)","id":"CVE-2023-51451","markdown":"https://insights.sbomify.com/CVE-2023-51451/index.md","name":"CVE-2023-51451","record":{"aliases":["GHSA-ghg9-7m82-h96r"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Sentry symbolicator service","requires_auth":"low_privilege","summary":"An attacker can force Symbolicator to send requests to internal IPs and expose responses via the API, requiring an upgrade to fix.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"symbolicator","vendor":"sentry"}],"cvss":{"score":4.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"Symbolicator is a service used in Sentry. Starting in Symbolicator version 0.3.3 and prior to version 21.12.1, an attacker could make Symbolicator send GET HTTP requests to arbitrary URLs with internal IP addresses by using an invalid protocol. The responses of those requests could be exposed via Symbolicator's API. In affected Sentry instances, the data could be exposed through the Sentry API and user interface if the attacker has a registered account. The issue has been fixed in Symbolicator release 23.12.1, Sentry self-hosted release 23.12.1, and has already been mitigated on sentry.io on December 18, 2023. If updating is not possible, some other mitigations are available. One may disable JS processing by toggling the option `Allow JavaScript Source Fetching` in `Organization Settings \u003e Security \u0026 Privacy` and/or disable all untrusted public repositories under `Project Settings \u003e Debug Files`. Alternatively, if JavaScript and native symbolication are not required, disable Symbolicator completely in `config.yml`.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"SSRF in symbolicator via invalid protocol","id":"CVE-2023-51451","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"ssrf","year":"2023"},"n_packages":0,"n_references":4,"next":{"headline":"Denial of service in Matrice 300","id":"CVE-2023-51452"},"packages":[],"prev":{"headline":"baserCMS OS command injection vulnerability in Installer","id":"CVE-2023-51450"},"products":["symbolicator"],"published":"2023-12-22","related":[{"cvss_score":4.3,"headline":"Symbolicator Server Side Request Forgery vulnerability","id":"CVE-2023-49094","kev_date_added":null,"published":"2023-11-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-02","vendors":["getsentry"]},"summary":"An attacker can force Symbolicator to send requests to internal IPs and expose responses via the API, requiring an upgrade to fix.","url":"https://insights.sbomify.com/CVE-2023-51451/"}