CVE-2023-51474 WordPress TerraClassifieds plugin <= 2.0.3 - Cross Site Request Forgery (CSRF) to Account Takeover vulnerability

High 8.8 Published Updated

A Cross-Site Request Forgery vulnerability in the TerraClassifieds WordPress plugin allows attackers to take over user accounts.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-51474?

CVE-2023-51474 is a high-severity vulnerability in Pixelemu TerraClassifieds, published on 16 Mar 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Cross-Site Request Forgery (CSRF) vulnerability in Pixelemu TerraClassifieds.This issue affects TerraClassifieds: from n/a through 2.0.3.

Weakness: CWE-352

Which versions are affected by CVE-2023-51474?

2 open source packages ship an affected version, including wordpress and wordpress-multisite.

PackageAffectedFixed in
wordpress BitnamiAll versions2.0.4
wordpress-multisite BitnamiAll versions2.0.4

How do I fix CVE-2023-51474?

Upgrade wordpress to 2.0.4 or later.

Is CVE-2023-51474 being exploited?

There is no known exploitation of CVE-2023-51474 in the wild and no public exploit code.

Sources

Also known as BIT-wordpress-2023-51474, BIT-wordpress-multisite-2023-51474, GHSA-557p-6hf2-6q66.

Is CVE-2023-51474 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free