{"answers":{"affected":"2 open source packages ship an affected version, including wordpress and wordpress-multisite.","exploited":"There is no known exploitation of CVE-2023-51474 in the wild and no public exploit code.","fix":"Upgrade wordpress to 2.0.4 or later.","what":"CVE-2023-51474 is a high-severity vulnerability in Pixelemu TerraClassifieds, published on 16 Mar 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-51474 and fix it if it is affected.\n\nWhat it is: CVE-2023-51474 is a high-severity vulnerability in Pixelemu TerraClassifieds, published on 16 Mar 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-51474 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wordpress (Bitnami): affected all versions; fixed in 2.0.4\n- wordpress-multisite (Bitnami): affected all versions; fixed in 2.0.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-51474/ (Markdown: https://insights.sbomify.com/CVE-2023-51474/index.md)","id":"CVE-2023-51474","markdown":"https://insights.sbomify.com/CVE-2023-51474/index.md","name":"CVE-2023-51474","record":{"aliases":["BIT-wordpress-2023-51474","BIT-wordpress-multisite-2023-51474","GHSA-557p-6hf2-6q66"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"none","summary":"A Cross-Site Request Forgery vulnerability in the TerraClassifieds WordPress plugin allows attackers to take over user accounts.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Patchstack","cpe":[],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"Cross-Site Request Forgery (CSRF) vulnerability in Pixelemu TerraClassifieds.This issue affects TerraClassifieds: from n/a through 2.0.3.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"WordPress TerraClassifieds plugin \u003c= 2.0.3 - Cross Site Request Forgery (CSRF) to Account Takeover vulnerability","id":"CVE-2023-51474","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"csrf","year":"2023"},"n_packages":2,"n_references":1,"next":{"headline":"WordPress WP MLM Unilevel Plugin \u003c= 4.0 is vulnerable to Arbitrary File Upload","id":"CVE-2023-51475"},"packages":[{"ecosystem":"Bitnami","fixed":["2.0.4"],"introduced":["0"],"last_affected":[],"package":"wordpress","purl":"pkg:bitnami/wordpress","source":"BIT-wordpress-2023-51474"},{"ecosystem":"Bitnami","fixed":["2.0.4"],"introduced":["0"],"last_affected":[],"package":"wordpress-multisite","purl":"pkg:bitnami/wordpress-multisite","source":"BIT-wordpress-multisite-2023-51474"}],"prev":{"headline":"WordPress TerraClassifieds Plugin \u003c= 2.0.3 is vulnerable to Arbitrary File Upload","id":"CVE-2023-51473"},"products":["TerraClassifieds"],"published":"2024-03-16","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-04-28","vendors":["Pixelemu"]},"summary":"A Cross-Site Request Forgery vulnerability in the TerraClassifieds WordPress plugin allows attackers to take over user accounts.","url":"https://insights.sbomify.com/CVE-2023-51474/"}