CVE-2023-51518 Apache James server: Privilege escalation via JMX pre-authentication deserialisation
Attackers with local access can exploit JMX deserialization to escalate privileges or execute code on Apache James servers.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-51518?
CVE-2023-51518 is a critical unsafe deserialization vulnerability in Apache James server, published on 27 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Apache James prior to version 3.7.5 and 3.8.0 exposes a JMX endpoint on localhost subject to pre-authentication deserialisation of untrusted data. Given a deserialisation gadjet, this could be leveraged as part of an exploit chain that could result in privilege escalation. Note that by default JMX endpoint is only bound locally.
We recommend users to: - Upgrade to a non-vulnerable Apache James version
- Run Apache James isolated from other processes (docker - dedicated virtual machine) - If possible turn off JMX
Weakness: CWE-502
Which versions are affected by CVE-2023-51518?
4 open source packages ship an affected version, including org.apache.james:james-server. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.james:james-server Maven | All versions | 3.7.5 |
org.apache.james:james-server Maven | All versions | 3.7.5 |
org.apache.james:james-server Maven | From 3.8.0 | 3.8.1 |
org.apache.james:james-server Maven | From 3.8.0 | 3.8.1 |
Products include Apache James.
How do I fix CVE-2023-51518?
Upgrade org.apache.james:james-server to a fixed version for your release line: 3.7.5 or 3.8.1.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2023-51518 being exploited?
There is no known exploitation of CVE-2023-51518 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Apache James server
- CVE-2019-0228 Vulnerability that affects org.apache.pdfbox:pdfbox
- CVE-2021-40525 Sieve file storage vulnerable to path traversal attacks
- CVE-2023-26269 Apache James server: Privilege escalation through unauthenticated JMX
- CVE-2006-2806 Denial of service in n/a
- CVE-2022-28220 STARTTLS command injection in Apache JAMES
Sources
Also known as GHSA-px7w-c9gw-7gj3.