{"answers":{"affected":"4 open source packages ship an affected version, including org.apache.james:james-server. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-51518 in the wild and no public exploit code.","fix":"Upgrade org.apache.james:james-server to a fixed version for your release line: 3.7.5 or 3.8.1.","what":"CVE-2023-51518 is a critical unsafe deserialization vulnerability in Apache James server, published on 27 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-51518 and fix it if it is affected.\n\nWhat it is: CVE-2023-51518 is a critical unsafe deserialization vulnerability in Apache James server, published on 27 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-51518 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.james:james-server (Maven): affected all versions; fixed in 3.7.5\n- org.apache.james:james-server (Maven): affected all versions; fixed in 3.7.5\n- org.apache.james:james-server (Maven): affected from 3.8.0; fixed in 3.8.1\n- org.apache.james:james-server (Maven): affected from 3.8.0; fixed in 3.8.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-51518/ (Markdown: https://insights.sbomify.com/CVE-2023-51518/index.md)","id":"CVE-2023-51518","markdown":"https://insights.sbomify.com/CVE-2023-51518/index.md","name":"CVE-2023-51518","record":{"aliases":["GHSA-px7w-c9gw-7gj3"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["privilege_escalation","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache James server","requires_auth":"none","summary":"Attackers with local access can exploit JMX deserialization to escalate privileges or execute code on Apache James servers.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"james","vendor":"apache"}],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"Apache James prior to version 3.7.5 and 3.8.0 exposes a JMX endpoint on localhost subject to pre-authentication deserialisation of untrusted data.\nGiven a deserialisation gadjet, this could be leveraged as part of an exploit chain that could result in privilege escalation.\nNote that by default JMX endpoint is only bound locally.\n\nWe recommend users to:\n - Upgrade to a non-vulnerable Apache James version\n\n - Run Apache James isolated from other processes (docker - dedicated virtual machine)\n - If possible turn off JMX","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":"2024-06-03","github_poc":1,"max_poc_stars":1,"metasploit":0,"nuclei":0,"refs":[{"date":"2024-06-03T19:48:53Z","kind":"github_poc","ref":"https://github.com/mbadanoiu/CVE-2023-51518","stars":1,"title":"CVE-2023-51518: Preauthenticated Java Deserialization via JMX in Apache James"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Apache James server: Privilege escalation via JMX pre-authentication deserialisation","id":"CVE-2023-51518","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"deserialization","year":"2023"},"n_packages":4,"n_references":1,"next":{"headline":"Missing authorization in Slider by Soliloquy","id":"CVE-2023-51519"},"packages":[{"ecosystem":"Maven","fixed":["3.7.5"],"introduced":["0"],"last_affected":[],"package":"org.apache.james:james-server","purl":null,"source":"GHSA-px7w-c9gw-7gj3"},{"ecosystem":"Maven","fixed":["3.7.5"],"introduced":["0"],"last_affected":[],"package":"org.apache.james:james-server","purl":"pkg:maven/org.apache.james/james-server","source":"GHSA-px7w-c9gw-7gj3"},{"ecosystem":"Maven","fixed":["3.8.1"],"introduced":["3.8.0"],"last_affected":[],"package":"org.apache.james:james-server","purl":null,"source":"GHSA-px7w-c9gw-7gj3"},{"ecosystem":"Maven","fixed":["3.8.1"],"introduced":["3.8.0"],"last_affected":[],"package":"org.apache.james:james-server","purl":"pkg:maven/org.apache.james/james-server","source":"GHSA-px7w-c9gw-7gj3"}],"prev":{"headline":"WordPress Calculated Fields Form Plugin \u003c= 1.2.28 is vulnerable to Open Redirection","id":"CVE-2023-51517"},"products":["Apache James server"],"published":"2024-02-27","related":[{"cvss_score":9.8,"headline":"Vulnerability that affects org.apache.pdfbox:pdfbox","id":"CVE-2019-0228","kev_date_added":null,"published":"2019-04-17"},{"cvss_score":9.1,"headline":"Sieve file storage vulnerable to path traversal attacks","id":"CVE-2021-40525","kev_date_added":null,"published":"2022-01-04"},{"cvss_score":7.8,"headline":"Apache James server: Privilege escalation through unauthenticated JMX","id":"CVE-2023-26269","kev_date_added":null,"published":"2023-04-03"},{"cvss_score":7.8,"headline":"Denial of service in n/a","id":"CVE-2006-2806","kev_date_added":null,"published":"2006-06-05"},{"cvss_score":7.5,"headline":"STARTTLS command injection in Apache JAMES","id":"CVE-2022-28220","kev_date_added":null,"published":"2022-09-08"},{"cvss_score":7.5,"headline":"Apache James IMAP vulnerable to a ReDoS","id":"CVE-2021-40110","kev_date_added":null,"published":"2022-01-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-08-22","vendors":["Apache Software Foundation"]},"summary":"Attackers with local access can exploit JMX deserialization to escalate privileges or execute code on Apache James servers.","url":"https://insights.sbomify.com/CVE-2023-51518/"}