# CVE-2023-51518: Apache James server: Privilege escalation via JMX pre-authentication deserialisation

> Attackers with local access can exploit JMX deserialization to escalate privileges or execute code on Apache James servers.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Feb 2024
- **Updated:** 22 Aug 2024
- **Also known as:** GHSA-px7w-c9gw-7gj3

## What is CVE-2023-51518?

CVE-2023-51518 is a critical unsafe deserialization vulnerability in Apache James server, published on 27 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache James prior to version 3.7.5 and 3.8.0 exposes a JMX endpoint on localhost subject to pre-authentication deserialisation of untrusted data.
Given a deserialisation gadjet, this could be leveraged as part of an exploit chain that could result in privilege escalation.
Note that by default JMX endpoint is only bound locally.

We recommend users to:
 - Upgrade to a non-vulnerable Apache James version

 - Run Apache James isolated from other processes (docker - dedicated virtual machine)
 - If possible turn off JMX

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2023-51518?

4 open source packages ship an affected version, including org.apache.james:james-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.james:james-server` | Maven | All versions | 3.7.5 |
| `org.apache.james:james-server` | Maven | All versions | 3.7.5 |
| `org.apache.james:james-server` | Maven | From 3.8.0 | 3.8.1 |
| `org.apache.james:james-server` | Maven | From 3.8.0 | 3.8.1 |

Products: Apache James.

## How do I fix CVE-2023-51518?

Upgrade org.apache.james:james-server to a fixed version for your release line: 3.7.5 or 3.8.1.

## Is CVE-2023-51518 being exploited?

There is no known exploitation of CVE-2023-51518 in the wild and no public exploit code.

Public exploit code:

- CVE-2023-51518: Preauthenticated Java Deserialization via JMX in Apache James (github_poc): https://github.com/mbadanoiu/CVE-2023-51518

## Other vulnerabilities in Apache James server

- [CVE-2019-0228](https://insights.sbomify.com/CVE-2019-0228/): Vulnerability that affects org.apache.pdfbox:pdfbox (critical 9.8)
- [CVE-2021-40525](https://insights.sbomify.com/CVE-2021-40525/): Sieve file storage vulnerable to path traversal attacks (critical 9.1)
- [CVE-2023-26269](https://insights.sbomify.com/CVE-2023-26269/): Apache James server: Privilege escalation through unauthenticated JMX (high 7.8)
- [CVE-2006-2806](https://insights.sbomify.com/CVE-2006-2806/): Denial of service in n/a (high 7.8)
- [CVE-2022-28220](https://insights.sbomify.com/CVE-2022-28220/): STARTTLS command injection in Apache JAMES (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-51518 and fix it if it is affected.

What it is: CVE-2023-51518 is a critical unsafe deserialization vulnerability in Apache James server, published on 27 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-51518 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.james:james-server (Maven): affected all versions; fixed in 3.7.5
- org.apache.james:james-server (Maven): affected all versions; fixed in 3.7.5
- org.apache.james:james-server (Maven): affected from 3.8.0; fixed in 3.8.1
- org.apache.james:james-server (Maven): affected from 3.8.0; fixed in 3.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-51518/ (Markdown: https://insights.sbomify.com/CVE-2023-51518/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-51518
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-51518
- OSV: https://osv.dev/vulnerability/CVE-2023-51518

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-51518/
Summaries are generated and may contain mistakes; the official description above is the record.
