# CVE-2023-51530: WordPress GS Logo Slider Plugin <= 3.5.1 is vulnerable to Cross Site Request Forgery (CSRF)

> Attackers can trick authenticated users into modifying logo slider settings via CSRF, requiring plugin updates.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 29 Feb 2024
- **Updated:** 28 Apr 2026
- **Also known as:** GHSA-6grj-8439-x6c5

## What is CVE-2023-51530?

CVE-2023-51530 is a medium-severity vulnerability in GS Plugins Logo Slider – Logo Showcase, Logo Carousel, Logo Gallery and Client Logo Presentation, published on 29 Feb 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-Site Request Forgery (CSRF) vulnerability in GS Plugins Logo Slider – Logo Showcase, Logo Carousel, Logo Gallery and Client Logo Presentation.This issue affects Logo Slider – Logo Showcase, Logo Carousel, Logo Gallery and Client Logo Presentation: from n/a through 3.5.1.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2023-51530?

It affects 1 product.


Products: Gsplugins Logo Slider.

## How do I fix CVE-2023-51530?

No fix has been published for CVE-2023-51530 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-51530 being exploited?

There is no known exploitation of CVE-2023-51530 in the wild and no public exploit code.

## Other vulnerabilities in GS Plugins Logo Slider – Logo Showcase, Logo Carousel, Logo Gallery and Client Logo Presentation

- [CVE-2024-9233](https://insights.sbomify.com/CVE-2024-9233/): GS Logo Slider < 3.7.1 - Settings Update via Cross-Site Request Forgery (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-51530 and fix it if it is affected.

What it is: CVE-2023-51530 is a medium-severity vulnerability in GS Plugins Logo Slider – Logo Showcase, Logo Carousel, Logo Gallery and Client Logo Presentation, published on 29 Feb 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-51530 in the wild and no public exploit code.

Affected product: GS Plugins Logo Slider – Logo Showcase, Logo Carousel, Logo Gallery and Client Logo Presentation. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-51530/ (Markdown: https://insights.sbomify.com/CVE-2023-51530/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-51530
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-51530
- OSV: https://osv.dev/vulnerability/CVE-2023-51530

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-51530/
Summaries are generated and may contain mistakes; the official description above is the record.
