# CVE-2023-51533: WordPress Ecwid Shopping Cart Plugin <= 6.12.4 is vulnerable to Cross Site Request Forgery (CSRF)

> Attackers can trick authenticated users into performing unintended actions in the Ecwid Shopping Cart plugin, potentially modifying store settings or data.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 28 Feb 2024
- **Updated:** 28 Apr 2026
- **Also known as:** GHSA-jfh3-wq2r-73gg

## What is CVE-2023-51533?

CVE-2023-51533 is a medium-severity vulnerability in Ecwid Ecommerce Shopping Cart, published on 28 Feb 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-Site Request Forgery (CSRF) vulnerability in Ecwid Ecommerce Ecwid Ecommerce Shopping Cart.This issue affects Ecwid Ecommerce Shopping Cart: from n/a through 6.12.4.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2023-51533?

It affects 1 product.


Products: Lightspeedhq Ecwid Ecommerce Shopping Cart.

## How do I fix CVE-2023-51533?

No fix has been published for CVE-2023-51533 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-51533 being exploited?

There is no known exploitation of CVE-2023-51533 in the wild and no public exploit code.

## Other vulnerabilities in Ecwid Ecommerce Shopping Cart

- [CVE-2022-2432](https://insights.sbomify.com/CVE-2022-2432/): Ecwid Ecommerce Shopping Cart <= 6.10.23 - Cross-Site Request Forgery to Settings/Options Update (high 8.8)
- [CVE-2023-24408](https://insights.sbomify.com/CVE-2023-24408/): WordPress Ecwid Shopping Cart Plugin <= 6.11.4 is vulnerable to Cross Site Scripting (XSS) (medium 6.5)
- [CVE-2024-13795](https://insights.sbomify.com/CVE-2024-13795/): Ecwid by Lightspeed Ecommerce Shopping Cart <= 6.12.27 - Cross-Site Request Forgery to Send Deactivation Message (medium 4.3)
- [CVE-2023-6292](https://insights.sbomify.com/CVE-2023-6292/): Ecwid Ecommerce Shopping Cart < 6.12.5 - Arbitrary Plugin Settings Change via CSRF (medium 4.3)
- [CVE-2023-24377](https://insights.sbomify.com/CVE-2023-24377/): WordPress Ecwid Shopping Cart Plugin <= 6.11.3 is vulnerable to Cross Site Request Forgery (CSRF) (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-51533 and fix it if it is affected.

What it is: CVE-2023-51533 is a medium-severity vulnerability in Ecwid Ecommerce Shopping Cart, published on 28 Feb 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-51533 in the wild and no public exploit code.

Affected product: Ecwid Ecommerce Shopping Cart. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-51533/ (Markdown: https://insights.sbomify.com/CVE-2023-51533/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-51533
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-51533
- OSV: https://osv.dev/vulnerability/CVE-2023-51533

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-51533/
Summaries are generated and may contain mistakes; the official description above is the record.
