# CVE-2023-51652: OWASP.AntiSamy mXSS when preserving comments

> Attackers can execute arbitrary scripts via mutation XSS in OWASP AntiSamy .NET when comment preservation is enabled.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Jan 2024
- **Updated:** 17 Apr 2025
- **Also known as:** GHSA-8x6f-956f-q43w

## What is CVE-2023-51652?

CVE-2023-51652 is a medium-severity cross-site scripting vulnerability in spassarop antisamy-dotnet, published on 2 Jan 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

OWASP AntiSamy .NET is a library for performing cleansing of HTML coming from untrusted sources. Prior to version 1.2.0, there is a potential for a mutation cross-site scripting (mXSS) vulnerability in AntiSamy caused by flawed parsing of the HTML being sanitized. To be subject to this vulnerability the `preserveComments` directive must be enabled in your policy file and also allow for certain tags at the same time. As a result, certain crafty inputs can result in elements in comment tags being interpreted as executable when using AntiSamy's sanitized output. This is patched in OWASP AntiSamy .NET 1.2.0 and later. See important remediation details in the reference given below. As a workaround, manually edit the AntiSamy policy file (e.g., antisamy.xml) by deleting the `preserveComments` directive or setting its value to `false`,  if present. Also it would be useful to make AntiSamy remove the `noscript` tag by adding a line described in the GitHub Security Advisory to the tag definitions under the `<tagrules>` node, or deleting it entirely if present. As the previously mentioned policy settings are preconditions for the mXSS attack to work, changing them as recommended should be sufficient to protect you against this vulnerability when using a vulnerable version of this library. However, the existing bug would still be present in AntiSamy or its parser dependency (HtmlAgilityPack). The safety of this workaround relies on configurations that may change in the future and don't address the root cause of the vulnerability. As such, it is strongly recommended to upgrade to a fixed version of AntiSamy.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-51652?

2 open source packages ship an affected version, including OWASP.AntiSamy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `OWASP.AntiSamy` | NuGet | All versions | 1.2.0 |
| `OWASP.AntiSamy` | NuGet | All versions | 1.2.0 |

Products: Spassarop Owasp Antisamy .Net.

## How do I fix CVE-2023-51652?

Upgrade OWASP.AntiSamy to 1.2.0 or later.

## Is CVE-2023-51652 being exploited?

There is no known exploitation of CVE-2023-51652 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-51652 and fix it if it is affected.

What it is: CVE-2023-51652 is a medium-severity cross-site scripting vulnerability in spassarop antisamy-dotnet, published on 2 Jan 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-51652 in the wild and no public exploit code.

Affected packages and fixed versions:
- OWASP.AntiSamy (NuGet): affected all versions; fixed in 1.2.0
- OWASP.AntiSamy (NuGet): affected all versions; fixed in 1.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-51652/ (Markdown: https://insights.sbomify.com/CVE-2023-51652/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-51652
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-51652
- OSV: https://osv.dev/vulnerability/CVE-2023-51652

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-51652/
Summaries are generated and may contain mistakes; the official description above is the record.
