{"answers":{"affected":"2 open source packages ship an affected version, including Snowflake.Data. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-51662 in the wild and no public exploit code.","fix":"Upgrade Snowflake.Data to 2.1.5 or later.","what":"CVE-2023-51662 is a medium-severity vulnerability in snowflakedb snowflake-connector-net, published on 22 Dec 2023. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-51662 and fix it if it is affected.\n\nWhat it is: CVE-2023-51662 is a medium-severity vulnerability in snowflakedb snowflake-connector-net, published on 22 Dec 2023. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-51662 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- Snowflake.Data (NuGet): affected from 2.0.25; fixed in 2.1.5\n- Snowflake.Data (NuGet): affected from 2.0.25; fixed in 2.1.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-51662/ (Markdown: https://insights.sbomify.com/CVE-2023-51662/index.md)","id":"CVE-2023-51662","markdown":"https://insights.sbomify.com/CVE-2023-51662/index.md","name":"CVE-2023-51662","record":{"aliases":["GHSA-hwcc-4cv8-cf3h"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Snowflake .NET connector","requires_auth":"high_privilege","summary":"The Snowflake .NET connector fails to check Certificate Revocation Lists by default, allowing attackers to bypass TLS certificate validation.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"snowflake_connector","vendor":"snowflake"}],"cvss":{"score":6,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:A/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:L","version":"3.1"},"cwes":[{"id":"CWE-295","name":"Improper Certificate Validation"}],"description":"The Snowflake .NET driver provides an interface to the Microsoft .NET open source software framework for developing applications. Snowflake recently received a report about a vulnerability in the Snowflake Connector .NET where the checks against the Certificate Revocation List (CRL) were not performed where the insecureMode flag was set to false, which is the default setting. The vulnerability affects versions between 2.0.25 and 2.1.4 (inclusive). Snowflake fixed the issue in version 2.1.5.","ecosystems":["NuGet"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Snowflake Connector .NET does not properly check the Certificate Revocation List (CRL)","id":"CVE-2023-51662","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"NuGet","product":null,"products":[],"type":"security_feature_bypass","year":"2023"},"n_packages":2,"n_references":2,"next":{"headline":"Hail authentication can be bypassed by changing email address","id":"CVE-2023-51663"},"packages":[{"ecosystem":"NuGet","fixed":["2.1.5"],"introduced":["2.0.25"],"last_affected":[],"package":"Snowflake.Data","purl":null,"source":"GHSA-hwcc-4cv8-cf3h"},{"ecosystem":"NuGet","fixed":["2.1.5"],"introduced":["2.0.25"],"last_affected":[],"package":"Snowflake.Data","purl":"pkg:nuget/Snowflake.Data","source":"GHSA-hwcc-4cv8-cf3h"}],"prev":{"headline":"Filesystem sandbox not enforced in wasmer-cli","id":"CVE-2023-51661"},"products":["snowflake-connector-net"],"published":"2023-12-22","related":[{"cvss_score":7.3,"headline":"Snowflake Connector vulnerable to Command Injection","id":"CVE-2023-34230","kev_date_added":null,"published":"2023-06-08"},{"cvss_score":7.3,"headline":"Snowflake NodeJS Driver vulnerable to Command Injection","id":"CVE-2023-34232","kev_date_added":null,"published":"2023-06-08"},{"cvss_score":7.3,"headline":"Snowflake Python Connector vulnerable to Command Injection","id":"CVE-2023-34233","kev_date_added":null,"published":"2023-06-08"},{"cvss_score":7,"headline":"Snowflake Connector for Python has an SQL Injection in write_pandas","id":"CVE-2025-24793","kev_date_added":null,"published":"2025-01-29"},{"cvss_score":6.7,"headline":"The Snowflake Connector for Python uses insecure deserialization of the OCSP response cache","id":"CVE-2025-24794","kev_date_added":null,"published":"2025-01-29"},{"cvss_score":5.5,"headline":"Snowflake Connector for Python has sensitive data in logs","id":"CVE-2024-49750","kev_date_added":null,"published":"2024-10-24"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-02","vendors":["snowflakedb"]},"summary":"The Snowflake .NET connector fails to check Certificate Revocation Lists by default, allowing attackers to bypass TLS certificate validation.","url":"https://insights.sbomify.com/CVE-2023-51662/"}