# CVE-2023-51699: OS Command Injection for Fluid Users with JuicefsRuntime

> Authenticated users with CRD creation rights can execute arbitrary OS commands in JuicefsRuntime containers, leading to unauthorized data access or modification.

- **Severity:** Medium 4.0 (`CVSS:3.1/AV:L/AC:H/PR:H/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Mar 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-wx8q-4gm9-rj2g, GO-2024-2644

## What is CVE-2023-51699?

CVE-2023-51699 is a medium-severity command injection vulnerability in fluid-cloudnative fluid, published on 15 Mar 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Fluid is an open source Kubernetes-native Distributed Dataset Orchestrator and Accelerator for data-intensive applications. An OS command injection vulnerability within the Fluid project's JuicefsRuntime can potentially allow an authenticated user, who has the authority to create or update the K8s CRD Dataset/JuicefsRuntime, to execute arbitrary OS commands within the juicefs related containers. This could lead to unauthorized access, modification or deletion of data. Users who're using versions < 0.9.3 with JuicefsRuntime should upgrade to v0.9.3.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2023-51699?

3 open source packages ship an affected version, including github.com/fluid-cloudnative/fluid. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/fluid-cloudnative/fluid` | Go | All versions | 0.9.3 |
| `github.com/fluid-cloudnative/fluid` | Go | All versions | 0.9.3 |
| `github.com/fluid-cloudnative/fluid` | Go | All versions | 0.9.3 |

Products: Linuxfoundation Fluid.

## How do I fix CVE-2023-51699?

Upgrade github.com/fluid-cloudnative/fluid to 0.9.3 or later.

## Is CVE-2023-51699 being exploited?

There is no known exploitation of CVE-2023-51699 in the wild and no public exploit code.

## Other vulnerabilities in fluid-cloudnative fluid

- [CVE-2023-30840](https://insights.sbomify.com/CVE-2023-30840/): On a compromised node, the fluid-csi service account can be used to modify node specs (medium 5.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-51699 and fix it if it is affected.

What it is: CVE-2023-51699 is a medium-severity command injection vulnerability in fluid-cloudnative fluid, published on 15 Mar 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-51699 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/fluid-cloudnative/fluid (Go): affected all versions; fixed in 0.9.3
- github.com/fluid-cloudnative/fluid (Go): affected all versions; fixed in 0.9.3
- github.com/fluid-cloudnative/fluid (Go): affected all versions; fixed in 0.9.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-51699/ (Markdown: https://insights.sbomify.com/CVE-2023-51699/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-51699
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-51699
- OSV: https://osv.dev/vulnerability/CVE-2023-51699

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-51699/
Summaries are generated and may contain mistakes; the official description above is the record.
