# CVE-2023-51701: @fastify-reply-from JSON Content-Type parsing confusion


- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 8 Jan 2024
- **Updated:** 3 Jun 2025
- **Also known as:** GHSA-v2v2-hph8-q5xp

## What is CVE-2023-51701?

CVE-2023-51701 is a medium-severity vulnerability in fastify-reply-from, published on 8 Jan 2024. 

### Official description

fastify-reply-from is a Fastify plugin to forward the current HTTP request to another server. A reverse proxy server built with `@fastify/reply-from` could misinterpret the incoming body by passing an header `ContentType: application/json ; charset=utf-8`. This can lead to bypass of security checks. This vulnerability has been patched in '@fastify/reply-from` version 9.6.0.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2023-51701?

2 open source packages ship an affected version, including @fastify/reply-from. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@fastify/reply-from` | npm | All versions | 9.6.0 |
| `@fastify/reply-from` | npm | All versions | 9.6.0 |

Products: Fastify Reply-From.

## How do I fix CVE-2023-51701?

Upgrade @fastify/reply-from to 9.6.0 or later.

## Is CVE-2023-51701 being exploited?

There is no known exploitation of CVE-2023-51701 in the wild and no public exploit code.

## Other vulnerabilities in fastify-reply-from

- [CVE-2025-66415](https://insights.sbomify.com/CVE-2025-66415/): fastify-reply-from bypass of reply forwarding (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-51701 and fix it if it is affected.

What it is: CVE-2023-51701 is a medium-severity vulnerability in fastify-reply-from, published on 8 Jan 2024. 
Exploitation: There is no known exploitation of CVE-2023-51701 in the wild and no public exploit code.

Affected packages and fixed versions:
- @fastify/reply-from (npm): affected all versions; fixed in 9.6.0
- @fastify/reply-from (npm): affected all versions; fixed in 9.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-51701/ (Markdown: https://insights.sbomify.com/CVE-2023-51701/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-51701
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-51701
- OSV: https://osv.dev/vulnerability/CVE-2023-51701

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-51701/
Summaries are generated and may contain mistakes; the official description above is the record.
