CVE-2023-51702 Apache Airflow CNCF Kubernetes provider, Apache Airflow: Kubernetes configuration file saved without encryption in the Metadata and logged as plain text in the Triggerer service
Attackers with metadata or log access can retrieve unencrypted Kubernetes configuration files, potentially gaining cluster access.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-51702?
CVE-2023-51702 is a medium-severity vulnerability in Apache Airflow, published on 24 Jan 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Since version 5.2.0, when using deferrable mode with the path of a Kubernetes configuration file for authentication, the Airflow worker serializes this configuration file as a dictionary and sends it to the triggerer by storing it in metadata without any encryption. Additionally, if used with an Airflow version between 2.3.0 and 2.6.0, the configuration dictionary will be logged as plain text in the triggerer service without masking. This allows anyone with access to the metadata or triggerer log to obtain the configuration file and use it to access the Kubernetes cluster.
This behavior was changed in version 7.0.0, which stopped serializing the file contents and started providing the file path instead to read the contents into the trigger. Users are recommended to upgrade to version 7.0.0, which fixes this issue.
Which versions are affected by CVE-2023-51702?
7 open source packages ship an affected version, including apache-airflow, airflow and apache-airflow-providers-cncf-kubernetes. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
apache-airflow PyPI | From 2.3.0 | 2.6.1 |
apache-airflow PyPI | From 2.3.0 | 2.6.1 |
apache-airflow PyPI | From 2.3.0 | 2.6.1 |
airflow Bitnami | From 2.3.0 | 2.6.1 |
apache-airflow-providers-cncf-kubernetes PyPI | From 5.2.0 | 7.0.0 |
apache-airflow-providers-cncf-kubernetes PyPI | From 5.2.0 | 7.0.0 |
1 more packages
apache-airflow-providers-cncf-kubernetes PyPI | From 5.2.0 | 7.0.0 |
Products include Apache Airflow, Apache Apache-Airflow-Providers-Cncf-Kubernetes.
How do I fix CVE-2023-51702?
Upgrade apache-airflow to 2.6.1 or later.
Is CVE-2023-51702 being exploited?
There is no known exploitation of CVE-2023-51702 in the wild and no public exploit code.
Other vulnerabilities in Apache Airflow
- CVE-2020-13927 Apache Airflow's Experimental API Authentication Bypass
- CVE-2020-11978 Apache Airflow Command Injection
- CVE-2026-33264 Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize()
- CVE-2023-25754 Apache Airflow: Privilege escalation using airflow logs
- CVE-2023-22884 Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow
Sources
Also known as BIT-airflow-2023-51702, GHSA-mg2x-mggj-6955, PYSEC-2026-1144, PYSEC-2026-2350.