# CVE-2023-51702: Apache Airflow CNCF Kubernetes provider, Apache Airflow: Kubernetes configuration file saved without encryption in the Metadata and logged as plain text in the Triggerer service

> Attackers with metadata or log access can retrieve unencrypted Kubernetes configuration files, potentially gaining cluster access.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Jan 2024
- **Updated:** 11 Jun 2025
- **Also known as:** BIT-airflow-2023-51702, GHSA-mg2x-mggj-6955, PYSEC-2026-1144, PYSEC-2026-2350

## What is CVE-2023-51702?

CVE-2023-51702 is a medium-severity vulnerability in Apache Airflow, published on 24 Jan 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Since version 5.2.0, when using deferrable mode with the path of a Kubernetes configuration file for authentication, the Airflow worker serializes this configuration file as a dictionary and sends it to the triggerer by storing it in metadata without any encryption. Additionally, if used with an Airflow version between 2.3.0 and 2.6.0, the configuration dictionary will be logged as plain text in the triggerer service without masking. This allows anyone with access to the metadata or triggerer log to obtain the configuration file and use it to access the Kubernetes cluster.

This behavior was changed in version 7.0.0, which stopped serializing the file contents and started providing the file path instead to read the contents into the trigger. Users are recommended to upgrade to version 7.0.0, which fixes this issue.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File), CWE-312 (Cleartext Storage of Sensitive Information)

## Which versions are affected by CVE-2023-51702?

7 open source packages ship an affected version, including apache-airflow, airflow and apache-airflow-providers-cncf-kubernetes. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | From 2.3.0 | 2.6.1 |
| `apache-airflow` | PyPI | From 2.3.0 | 2.6.1 |
| `apache-airflow` | PyPI | From 2.3.0 | 2.6.1 |
| `airflow` | Bitnami | From 2.3.0 | 2.6.1 |
| `apache-airflow-providers-cncf-kubernetes` | PyPI | From 5.2.0 | 7.0.0 |
| `apache-airflow-providers-cncf-kubernetes` | PyPI | From 5.2.0 | 7.0.0 |
| `apache-airflow-providers-cncf-kubernetes` | PyPI | From 5.2.0 | 7.0.0 |

Products: Apache Airflow, Apache Apache-Airflow-Providers-Cncf-Kubernetes.

## How do I fix CVE-2023-51702?

Upgrade apache-airflow to 2.6.1 or later.

## Is CVE-2023-51702 being exploited?

There is no known exploitation of CVE-2023-51702 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-51702 and fix it if it is affected.

What it is: CVE-2023-51702 is a medium-severity vulnerability in Apache Airflow, published on 24 Jan 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-51702 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected from 2.3.0; fixed in 2.6.1
- apache-airflow (PyPI): affected from 2.3.0; fixed in 2.6.1
- apache-airflow (PyPI): affected from 2.3.0; fixed in 2.6.1
- airflow (Bitnami): affected from 2.3.0; fixed in 2.6.1
- apache-airflow-providers-cncf-kubernetes (PyPI): affected from 5.2.0; fixed in 7.0.0
- apache-airflow-providers-cncf-kubernetes (PyPI): affected from 5.2.0; fixed in 7.0.0
- apache-airflow-providers-cncf-kubernetes (PyPI): affected from 5.2.0; fixed in 7.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-51702/ (Markdown: https://insights.sbomify.com/CVE-2023-51702/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-51702
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-51702
- OSV: https://osv.dev/vulnerability/CVE-2023-51702

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-51702/
Summaries are generated and may contain mistakes; the official description above is the record.
