CVE-2023-51704 Cross-site scripting in n/a
Cross-site scripting vulnerability in MediaWiki allows attackers to execute arbitrary scripts via group member messages on the rights log page.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2023-51704?
CVE-2023-51704 is a medium-severity cross-site scripting vulnerability in Mediawiki Mediawiki, published on 22 Dec 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
An issue was discovered in MediaWiki before 1.35.14, 1.36.x through 1.39.x before 1.39.6, and 1.40.x before 1.40.2. In includes/logging/RightsLogFormatter.php, group-*-member messages can result in XSS on Special:log/rights.
Weakness: CWE-79
Which versions are affected by CVE-2023-51704?
1 open source package ship an affected version, including mediawiki. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
mediawiki Bitnami | All versions | 1.35.14, 1.39.6, 1.40.2 |
Products include Mediawiki Mediawiki.
How do I fix CVE-2023-51704?
Upgrade mediawiki to a fixed version for your release line: 1.35.14, 1.39.6 or 1.40.2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2023-51704 being exploited?
There is no known exploitation of CVE-2023-51704 in the wild and no public exploit code.
Other vulnerabilities in Mediawiki Mediawiki
Sources
Also known as BIT-mediawiki-2023-51704, DEBIAN-CVE-2023-51704, DLA-3896-1, GHSA-pmh9-hwq5-vvpj, UBUNTU-CVE-2023-51704.