CVE-2023-51747 SMTP smuggling in Apache James

High 7.1 Published Updated

Attackers can forge SMTP envelopes to bypass SPF checks due to lenient line delimiter handling in Apache James mail server.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-51747?

CVE-2023-51747 is a high-severity vulnerability in Apache James server, published on 27 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Apache James prior to versions 3.8.1 and 3.7.5 is vulnerable to SMTP smuggling.

A lenient behaviour in line delimiter handling might create a difference of interpretation between the sender and the receiver which can be exploited by an attacker to forge an SMTP envelop, allowing for instance to bypass SPF checks.

The patch implies enforcement of CRLF as a line delimiter as part of the DATA transaction.

We recommend James users to upgrade to non vulnerable versions.

Weakness: CWE-444, CWE-290, CWE-20

Which versions are affected by CVE-2023-51747?

4 open source packages ship an affected version, including org.apache.james:james-server. It affects 1 product.

PackageAffectedFixed in
org.apache.james:james-server MavenAll versions3.7.5
org.apache.james:james-server MavenAll versions3.7.5
org.apache.james:james-server MavenFrom 3.8.03.8.1
org.apache.james:james-server MavenFrom 3.8.03.8.1

Products include Apache James.

How do I fix CVE-2023-51747?

Upgrade org.apache.james:james-server to a fixed version for your release line: 3.7.5 or 3.8.1.

Is CVE-2023-51747 being exploited?

There is no known exploitation of CVE-2023-51747 in the wild and no public exploit code.

Sources

Also known as GHSA-p5q9-86w4-2xr5.

Is CVE-2023-51747 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free