# CVE-2023-51747: SMTP smuggling in Apache James

> Attackers can forge SMTP envelopes to bypass SPF checks due to lenient line delimiter handling in Apache James mail server.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Feb 2024
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-p5q9-86w4-2xr5

## What is CVE-2023-51747?

CVE-2023-51747 is a high-severity vulnerability in Apache James server, published on 27 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Apache James prior to versions 3.8.1 and 3.7.5 is vulnerable to SMTP smuggling.

A lenient behaviour in line delimiter handling might create a difference of interpretation between the sender and the receiver which can be exploited by an attacker to forge an SMTP envelop, allowing for instance to bypass SPF checks.

The patch implies enforcement of CRLF as a line delimiter as part of the DATA transaction.

We recommend James users to upgrade to non vulnerable versions.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests), CWE-290 (Authentication Bypass by Spoofing), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2023-51747?

4 open source packages ship an affected version, including org.apache.james:james-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.james:james-server` | Maven | All versions | 3.7.5 |
| `org.apache.james:james-server` | Maven | All versions | 3.7.5 |
| `org.apache.james:james-server` | Maven | From 3.8.0 | 3.8.1 |
| `org.apache.james:james-server` | Maven | From 3.8.0 | 3.8.1 |

Products: Apache James.

## How do I fix CVE-2023-51747?

Upgrade org.apache.james:james-server to a fixed version for your release line: 3.7.5 or 3.8.1.

## Is CVE-2023-51747 being exploited?

There is no known exploitation of CVE-2023-51747 in the wild and no public exploit code.

## Other vulnerabilities in Apache James server

- [CVE-2023-51518](https://insights.sbomify.com/CVE-2023-51518/): Apache James server: Privilege escalation via JMX pre-authentication deserialisation (critical 9.8)
- [CVE-2019-0228](https://insights.sbomify.com/CVE-2019-0228/): Vulnerability that affects org.apache.pdfbox:pdfbox (critical 9.8)
- [CVE-2021-40525](https://insights.sbomify.com/CVE-2021-40525/): Sieve file storage vulnerable to path traversal attacks (critical 9.1)
- [CVE-2023-26269](https://insights.sbomify.com/CVE-2023-26269/): Apache James server: Privilege escalation through unauthenticated JMX (high 7.8)
- [CVE-2006-2806](https://insights.sbomify.com/CVE-2006-2806/): Denial of service in n/a (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-51747 and fix it if it is affected.

What it is: CVE-2023-51747 is a high-severity vulnerability in Apache James server, published on 27 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-51747 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.james:james-server (Maven): affected all versions; fixed in 3.7.5
- org.apache.james:james-server (Maven): affected all versions; fixed in 3.7.5
- org.apache.james:james-server (Maven): affected from 3.8.0; fixed in 3.8.1
- org.apache.james:james-server (Maven): affected from 3.8.0; fixed in 3.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-51747/ (Markdown: https://insights.sbomify.com/CVE-2023-51747/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-51747
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-51747
- OSV: https://osv.dev/vulnerability/CVE-2023-51747

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-51747/
Summaries are generated and may contain mistakes; the official description above is the record.
