# CVE-2023-51763: ActiveAdmin CSV Injection leading to sensitive information disclosure

> ActiveAdmin allows CSV injection, potentially enabling code execution when exported files are opened in spreadsheet software.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Dec 2023
- **Updated:** 23 Feb 2026
- **Also known as:** GHSA-xhvv-3jww-c487

## What is CVE-2023-51763?

CVE-2023-51763 is a critical vulnerability in n/a, published on 24 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

csv_builder.rb in ActiveAdmin (aka Active Admin) before 3.2.0 allows CSV injection.

Weakness: CWE-1236 (Improper Neutralization of Formula Elements in a CSV File)

## Which versions are affected by CVE-2023-51763?

2 open source packages ship an affected version, including activeadmin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `activeadmin` | RubyGems | All versions | 3.2.0 |
| `activeadmin` | RubyGems | All versions | 3.2.0 |

Products: Activeadmin Active Admin.

## How do I fix CVE-2023-51763?

Upgrade activeadmin to 3.2.0 or later.

## Is CVE-2023-51763 being exploited?

There is no known exploitation of CVE-2023-51763 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-51763 and fix it if it is affected.

What it is: CVE-2023-51763 is a critical vulnerability in n/a, published on 24 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-51763 in the wild and no public exploit code.

Affected packages and fixed versions:
- activeadmin (RubyGems): affected all versions; fixed in 3.2.0
- activeadmin (RubyGems): affected all versions; fixed in 3.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-51763/ (Markdown: https://insights.sbomify.com/CVE-2023-51763/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-51763
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-51763
- OSV: https://osv.dev/vulnerability/CVE-2023-51763

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-51763/
Summaries are generated and may contain mistakes; the official description above is the record.
