# CVE-2023-51842: MeshCentral algorithm-downgrade issue

> Attackers can downgrade encryption algorithms in MeshCentral, weakening security protections for remote management sessions.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Jan 2024
- **Updated:** 2 Jun 2025
- **Also known as:** GHSA-wpxw-5xfm-x22v

## What is CVE-2023-51842?

CVE-2023-51842 is a high-severity vulnerability in n/a, published on 29 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An algorithm-downgrade issue was discovered in Ylianst MeshCentral 1.1.16.

## Which versions are affected by CVE-2023-51842?

2 open source packages ship an affected version, including meshcentral. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `meshcentral` | npm | All versions | 1.1.17 |
| `meshcentral` | npm | All versions | 1.1.17 |

Products: Meshcentral Meshcentral.

## How do I fix CVE-2023-51842?

Upgrade meshcentral to 1.1.17 or later.

## Is CVE-2023-51842 being exploited?

There is no known exploitation of CVE-2023-51842 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-51837](https://insights.sbomify.com/CVE-2023-51837/): Ylianst MeshCentral Missing SSL Certificate Validation (critical 9.8)
- [CVE-2024-26135](https://insights.sbomify.com/CVE-2024-26135/): MeshCentral cross-site websocket hijacking (CSWSH) vulnerability (high 8.4)
- [CVE-2023-51838](https://insights.sbomify.com/CVE-2023-51838/): Ylianst MeshCentral 1.1.16 suffers from Use of a Broken or Risky Cryptographic Algorithm. (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-51842 and fix it if it is affected.

What it is: CVE-2023-51842 is a high-severity vulnerability in n/a, published on 29 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-51842 in the wild and no public exploit code.

Affected packages and fixed versions:
- meshcentral (npm): affected all versions; fixed in 1.1.17
- meshcentral (npm): affected all versions; fixed in 1.1.17

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-51842/ (Markdown: https://insights.sbomify.com/CVE-2023-51842/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-51842
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-51842
- OSV: https://osv.dev/vulnerability/CVE-2023-51842

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-51842/
Summaries are generated and may contain mistakes; the official description above is the record.
