# CVE-2023-5192: Excessive Data Query Operations in a Large Data Table in pimcore/demo

> Attackers can cause denial of service by triggering excessive data query operations in large data tables within the Pimcore demo application.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Sep 2023
- **Updated:** 24 Sep 2024
- **Also known as:** GHSA-p76j-h4m8-hx5c

## What is CVE-2023-5192?

CVE-2023-5192 is a medium-severity denial of service vulnerability in pimcore/demo, published on 26 Sep 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Excessive Data Query Operations in a Large Data Table in GitHub repository pimcore/demo prior to 10.3.0.

Weakness: CWE-1049 (Excessive Data Query Operations in a Large Data Table)

## Which versions are affected by CVE-2023-5192?

2 open source packages ship an affected version, including pimcore/demo. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pimcore/demo` | Packagist | All versions | 10.3.0 |
| `pimcore/demo` | Packagist | All versions | 10.3.0 |

Products: Pimcore Core.

## How do I fix CVE-2023-5192?

Upgrade pimcore/demo to 10.3.0 or later.

## Is CVE-2023-5192 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-5192 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-5192 and fix it if it is affected.

What it is: CVE-2023-5192 is a medium-severity denial of service vulnerability in pimcore/demo, published on 26 Sep 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-5192 exists.

Affected packages and fixed versions:
- pimcore/demo (Packagist): affected all versions; fixed in 10.3.0
- pimcore/demo (Packagist): affected all versions; fixed in 10.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-5192/ (Markdown: https://insights.sbomify.com/CVE-2023-5192/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-5192
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-5192
- OSV: https://osv.dev/vulnerability/CVE-2023-5192

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-5192/
Summaries are generated and may contain mistakes; the official description above is the record.
