CVE-2023-5207 Execution with Unnecessary Privileges in GitLab
An authenticated attacker can execute arbitrary pipelines as another user, leading to privilege escalation and code execution in GitLab.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-5207?
CVE-2023-5207 is a high-severity vulnerability in Gitlab Gitlab, published on 30 Sep 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A vulnerability was discovered in GitLab CE and EE affecting all versions starting 16.0 prior to 16.2.8, 16.3 prior to 16.3.5, and 16.4 prior to 16.4.1. An authenticated attacker could perform arbitrary pipeline execution under the context of another user.
Weakness: CWE-250
Which versions are affected by CVE-2023-5207?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 16.0.0 | 16.2.8, 16.3.5, 16.4.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2023-5207?
Upgrade gitlab to a fixed version for your release line: 16.2.8, 16.3.5 or 16.4.1.
Is CVE-2023-5207 being exploited?
There is no known exploitation of CVE-2023-5207 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2023-5207, GHSA-m4hq-98c3-4xmx, UBUNTU-CVE-2023-5207.