# CVE-2023-52077: External apps using tokens issued by administrators and moderators can call admin APIs

> Malicious third-party apps with admin tokens can access admin APIs to modify settings and steal credentials in Nexkey.

- **Severity:** High 8.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 27 Dec 2023
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-pjj7-7hcj-9cpc

## What is CVE-2023-52077?

CVE-2023-52077 is a high-severity missing authorization vulnerability in nexryai nexkey, published on 27 Dec 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Nexkey is a lightweight fork of Misskey v12 optimized for small to medium size servers. Prior to 12.23Q4.5, Nexkey allows external apps using tokens issued by administrators and moderators to call admin APIs.  This allows malicious third-party apps to perform operations such as updating server settings, as well as compromise object storage and email server credentials. This issue has been patched in 12.23Q4.5.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2023-52077?

It affects 1 product.


Products: Nexryai Nexkey.

## How do I fix CVE-2023-52077?

No fix has been published for CVE-2023-52077 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-52077 being exploited?

There is no known exploitation of CVE-2023-52077 in the wild and no public exploit code.

## Other vulnerabilities in nexryai nexkey

- [CVE-2023-49095](https://insights.sbomify.com/CVE-2023-49095/): nexkey allows arbitrary users to impersonate any remote user due to missing signature validation (high 8.6)
- [CVE-2023-43805](https://insights.sbomify.com/CVE-2023-43805/): Nexkey allows users to bypass authentication of Bull dashboard (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-52077 and fix it if it is affected.

What it is: CVE-2023-52077 is a high-severity missing authorization vulnerability in nexryai nexkey, published on 27 Dec 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-52077 in the wild and no public exploit code.

Affected product: nexryai nexkey. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-52077/ (Markdown: https://insights.sbomify.com/CVE-2023-52077/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-52077
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-52077
- OSV: https://osv.dev/vulnerability/CVE-2023-52077

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-52077/
Summaries are generated and may contain mistakes; the official description above is the record.
