# CVE-2023-52079: Conversion of property names to strings can trigger infinite recursion

> Attackers can cause denial of service in msgpackr by sending crafted messages that trigger infinite recursion during decoding.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Dec 2023
- **Updated:** 27 Aug 2024
- **Also known as:** GHSA-7hpj-7hhx-2fgx

## What is CVE-2023-52079?

CVE-2023-52079 is a medium-severity denial of service vulnerability in kriszyp msgpackr, published on 28 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

msgpackr is a fast MessagePack NodeJS/JavaScript implementation. Prior to 1.10.1, when decoding user supplied MessagePack messages, users can trigger stuck threads by crafting messages that keep the decoder stuck in a loop. The fix is available in v1.10.1.  
Exploits seem to require structured cloning, replacing the 0x70 extension with your own (that throws an error or does something other than recursive referencing) should mitigate the issue.

Weakness: CWE-754 (Improper Check for Unusual or Exceptional Conditions), CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2023-52079?

2 open source packages ship an affected version, including msgpackr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `msgpackr` | npm | All versions | 1.10.1 |
| `msgpackr` | npm | All versions | 1.10.1 |

Products: Kriszyp Msgpackr.

## How do I fix CVE-2023-52079?

Upgrade msgpackr to 1.10.1 or later.

## Is CVE-2023-52079 being exploited?

There is no known exploitation of CVE-2023-52079 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-52079 and fix it if it is affected.

What it is: CVE-2023-52079 is a medium-severity denial of service vulnerability in kriszyp msgpackr, published on 28 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-52079 in the wild and no public exploit code.

Affected packages and fixed versions:
- msgpackr (npm): affected all versions; fixed in 1.10.1
- msgpackr (npm): affected all versions; fixed in 1.10.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-52079/ (Markdown: https://insights.sbomify.com/CVE-2023-52079/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-52079
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-52079
- OSV: https://osv.dev/vulnerability/CVE-2023-52079

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-52079/
Summaries are generated and may contain mistakes; the official description above is the record.
