CVE-2023-5212 Path traversal in WPBot – AI ChatBot for Live Support, Lead Generation, AI Services
Authenticated subscribers can delete arbitrary files via path traversal, potentially leading to site takeover.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2023-5212?
CVE-2023-5212 is a critical path traversal vulnerability in quantumcloud WPBot – AI ChatBot for Live Support, Lead Generation, AI Services, published on 19 Oct 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
The AI ChatBot plugin for WordPress is vulnerable to Arbitrary File Deletion in versions up to, and including, 4.8.9 as well as version 4.9.2. This makes it possible for authenticated attackers with subscriber privileges to delete arbitrary files on the server, which makes it possible to take over affected sites as well as others sharing the same hosting account. Version 4.9.1 originally addressed the issue, but it was reintroduced in 4.9.2 and fixed again in 4.9.3.
Weakness: CWE-22
Which versions are affected by CVE-2023-5212?
It affects 1 product.
Products include Quantumcloud Wpbot.
How do I fix CVE-2023-5212?
No fix has been published for CVE-2023-5212 yet. Limit exposure of the affected software until one is available.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2023-5212 being exploited?
There is no known exploitation of CVE-2023-5212 in the wild and no public exploit code.
Other vulnerabilities in quantumcloud WPBot – AI ChatBot for Live Support, Lead Generation, AI Services
- CVE-2023-5204 AI ChatBot <= 4.8.9 - Unauthenticated SQL Injection via qc_wpbo_search_response
- CVE-2023-1650 ChatBot < 4.4.7 - Unauthenticated PHP Object Injection
- CVE-2023-5241 Path traversal in WPBot – AI ChatBot for Live Support, Lead Generation, AI Services
- CVE-2024-22309 WordPress ChatBot Plugin <= 5.1.0 is vulnerable to PHP Object Injection
- CVE-2023-48741 WordPress ChatBot Plugin <= 4.7.8 is vulnerable to SQL Injection
Sources
Also known as CVE-2023-5647, GHSA-phr8-8r83-j89w.