# CVE-2023-52136: WordPress Custom Twitter Feeds (Tweets Widget) Plugin <= 2.1.2 is vulnerable to Cross Site Request Forgery (CSRF)

> Attackers can trick authenticated users into performing unwanted actions in the Custom Twitter Feeds WordPress plugin.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 5 Jan 2024
- **Updated:** 28 Apr 2026
- **Also known as:** GHSA-fmvv-rrvc-rh7f

## What is CVE-2023-52136?

CVE-2023-52136 is a medium-severity vulnerability in Smash Balloon Custom Twitter Feeds – A Tweets Widget or X Feed Widget, published on 5 Jan 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-Site Request Forgery (CSRF) vulnerability in Smash Balloon Custom Twitter Feeds – A Tweets Widget or X Feed Widget.This issue affects Custom Twitter Feeds – A Tweets Widget or X Feed Widget: from n/a through 2.1.2.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2023-52136?

It affects 1 product.


Products: Smashballoon Custom Twitter Feeds.

## How do I fix CVE-2023-52136?

No fix has been published for CVE-2023-52136 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-52136 being exploited?

There is no known exploitation of CVE-2023-52136 in the wild and no public exploit code.

## Other vulnerabilities in Smash Balloon Custom Twitter Feeds – A Tweets Widget or X Feed Widget

- [CVE-2024-49685](https://insights.sbomify.com/CVE-2024-49685/): WordPress Custom Twitter Feeds plugin <= 2.2.3 - Cross Site Request Forgery (CSRF) vulnerability (medium 5.4)
- [CVE-2022-33974](https://insights.sbomify.com/CVE-2022-33974/): WordPress Custom Twitter Feeds (Tweets Widget) Plugin <= 1.8.4 is vulnerable to Cross Site Request Forgery (CSRF) (medium 5.4)
- [CVE-2024-8983](https://insights.sbomify.com/CVE-2024-8983/): Custom Twitter Feeds < 2.2.3 - Admin+ Stored XSS (medium 4.8)
- [CVE-2024-0379](https://insights.sbomify.com/CVE-2024-0379/): Custom Twitter Feeds – A Tweets Widget or X Feed Widget <= 2.2.1 - Cross-Site Request Forgery to Plugin Options Update (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-52136 and fix it if it is affected.

What it is: CVE-2023-52136 is a medium-severity vulnerability in Smash Balloon Custom Twitter Feeds – A Tweets Widget or X Feed Widget, published on 5 Jan 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-52136 in the wild and no public exploit code.

Affected product: Smash Balloon Custom Twitter Feeds – A Tweets Widget or X Feed Widget. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-52136/ (Markdown: https://insights.sbomify.com/CVE-2023-52136/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-52136
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-52136
- OSV: https://osv.dev/vulnerability/CVE-2023-52136

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-52136/
Summaries are generated and may contain mistakes; the official description above is the record.
