{"answers":{"affected":"2 open source packages ship an affected version, including bolt. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-5214 in the wild and no public exploit code.","fix":"Upgrade bolt to 3.27.4 or later.","what":"CVE-2023-5214 is a medium-severity vulnerability in Puppet Bolt, published on 6 Oct 2023."},"fix_prompt":"Check this codebase for CVE-2023-5214 and fix it if it is affected.\n\nWhat it is: CVE-2023-5214 is a medium-severity vulnerability in Puppet Bolt, published on 6 Oct 2023. \nExploitation: There is no known exploitation of CVE-2023-5214 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- bolt (RubyGems): affected all versions; fixed in 3.27.4\n- bolt (RubyGems): affected all versions; fixed in 3.27.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-5214/ (Markdown: https://insights.sbomify.com/CVE-2023-5214/index.md)","id":"CVE-2023-5214","markdown":"https://insights.sbomify.com/CVE-2023-5214/index.md","name":"CVE-2023-5214","record":{"aliases":["AZL-110324","GHSA-289m-2964-f8q5"],"analysis":null,"analysis_generated_by":null,"assigner":"puppet","cpe":[{"product":"bolt","vendor":"puppet"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:A/AC:H/PR:L/UI:N/S:C/C:L/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-269","name":"Improper Privilege Management"}],"description":"In Puppet Bolt versions prior to 3.27.4, a path to escalate privileges was identified.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"CVE-2023-5214 - Privilege Escalation in Puppet Bolt","id":"CVE-2023-5214","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":null,"year":"2023"},"n_packages":2,"n_references":1,"next":{"headline":"Libnbd: crash or misbehaviour when nbd server returns an unexpected block size","id":"CVE-2023-5215"},"packages":[{"ecosystem":"RubyGems","fixed":["3.27.4"],"introduced":["0"],"last_affected":[],"package":"bolt","purl":null,"source":"GHSA-289m-2964-f8q5"},{"ecosystem":"RubyGems","fixed":["3.27.4"],"introduced":["0"],"last_affected":[],"package":"bolt","purl":"pkg:gem/bolt","source":"GHSA-289m-2964-f8q5"}],"prev":{"headline":"Path traversal in WPBot – AI ChatBot for Live Support, Lead Generation, AI Services","id":"CVE-2023-5212"},"products":["Bolt"],"published":"2023-10-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-09-19","vendors":["Puppet"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2023-5214/"}