# CVE-2023-5214: CVE-2023-5214 - Privilege Escalation in Puppet Bolt


- **Severity:** Medium 6.5 (`CVSS:3.1/AV:A/AC:H/PR:L/UI:N/S:C/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 6 Oct 2023
- **Updated:** 19 Sep 2024
- **Also known as:** AZL-110324, GHSA-289m-2964-f8q5

## What is CVE-2023-5214?

CVE-2023-5214 is a medium-severity vulnerability in Puppet Bolt, published on 6 Oct 2023. 

### Official description

In Puppet Bolt versions prior to 3.27.4, a path to escalate privileges was identified.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2023-5214?

2 open source packages ship an affected version, including bolt. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bolt` | RubyGems | All versions | 3.27.4 |
| `bolt` | RubyGems | All versions | 3.27.4 |

Products: Puppet Bolt.

## How do I fix CVE-2023-5214?

Upgrade bolt to 3.27.4 or later.

## Is CVE-2023-5214 being exploited?

There is no known exploitation of CVE-2023-5214 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-5214 and fix it if it is affected.

What it is: CVE-2023-5214 is a medium-severity vulnerability in Puppet Bolt, published on 6 Oct 2023. 
Exploitation: There is no known exploitation of CVE-2023-5214 in the wild and no public exploit code.

Affected packages and fixed versions:
- bolt (RubyGems): affected all versions; fixed in 3.27.4
- bolt (RubyGems): affected all versions; fixed in 3.27.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-5214/ (Markdown: https://insights.sbomify.com/CVE-2023-5214/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-5214
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-5214
- OSV: https://osv.dev/vulnerability/CVE-2023-5214

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-5214/
Summaries are generated and may contain mistakes; the official description above is the record.
